Odpowiedź forum utworzona

Viewing 6 replies - 1 through 6 (of 6 total)
  • Forum: Wtyczki
    W odpowiedzi na: NIe działaja pluginy galerii
    Thread Starter eFKa13

    (@efka13)

    Jeżeli dobrze zrozumiałam, to są tam dwie porady: pierwsza dotyczy kolejności dodawania wpisów w function.php, a druga, żeby z różnych metod dodawania css i js wybrać wp_enqueue_ (ja używałam (wp_reqiater_) , ale nic mi to nie pomogło. Zresztą nie dziwi mnie to, ponieważ próbowałam już wcześniej wyciąć wszystkie dodawane przez mnie skrypty i css i nic to nie pomogło. Wywaliłam zupełnie wszytko, co miałam w function.php i header.php (doty. js i css) i nic. W momencie dodawania jakiegokolwiek plugina galerii klapa. Gdy nie dodaje pluginów galerii wszytko śmiga pięknie.

    Bootstampa dodaje poprzez plugin bootstamp shorcode i jest to chyba najlepsza metoda? Tak, miałam jeszcze dodawanie w function.php, ale już się ich pozbyłam, bardzo dziękuje za tę uwagę…

    Co więcej: w momencie gdy pozostawię tylko prawie pusty index.php i style.css oraz folder z grafikami mam dokładnie ten sam błąd. Więc nie wiem nawet gdzie miałabym szukać tych niepoprawnie dodanych wp_enqueue_

    Czyli jak na razie nic mi nie pomogło 🙁 Co to może być? I dlaczego tylko pluginy galeri?

    • Ta odpowiedź została zmodyfikowana 7 years, 11 months temu przez eFKa13.
    • Ta odpowiedź została zmodyfikowana 7 years, 11 months temu przez eFKa13.
    Thread Starter eFKa13

    (@efka13)

    Bardzo proszę o pomoc. Z błędem dałam sobie radę, ale nie mogę dodać podstron pluginu. A raczej jedną mi się udało, a zrobiłam to tak:

    add_action('admin_menu', 'findDocMainItem');
    
    function findDocMainItem() {
    
    	add_menu_page('findDocPlug', 'znajdź lekarza', 'administrator', __FILE__, 'findDocOpt');
    
    	add_action( 'admin_init', 'findDocOptReg' );
    }
    
    add_action('admin_menu', 'findDocAddItem');
    
    function findDocAddItem() {
    
    	add_submenu_page( __FILE__, 'Dodaj', 'Dodaj', 'administrator', 'find-doc-add',  'findDocAdd');
    
    	add_action( 'admin_init', 'findDocAddReg' );
    }

    ale gdy próbuję dodać tak więcej podstron, nie wyświetlają mi się. Naprawdę nie wiem co robię źle. Naprawdę proszę o jakieś wskazówki…

    Thread Starter eFKa13

    (@efka13)

    Na wstępie bardzo chcę podziękować za odpowiedz.

    Udało się 🙂 Okazało się,że pomimo dodania odpowiedniego wpisu w wp-config (
    define(’WP_HOME’,’http://example.com’);
    define(’WP_SITEURL’,’http://example.com’); – tak dodałam to już wcześniej)

    oraz użycia velvet-blues-update-urls w taleli wp_options miałam nie zamienione ścieżki siteurl i home

    Niby taki drobiazg, a nie mogłam go znaleźć tyle czasu…

    Thread Starter eFKa13

    (@efka13)

    Czy tutaj ktokolwiek pomaga? Jeżeli nie napisałam czegoś ważnego w opisie powyżej to mi to powiedzcie! Bo nie wiem co jeszcze mogę robić źle, że mi nikt nie odpowiada!?

    Thread Starter eFKa13

    (@efka13)

    To może ktoś mi będzie umiał powiedzieć jak postępować, gdy w takiej sytuacji:
    w index.php miałam includowany plik z skryptem php wyciągającym z bazy wpisy o kategorii aktualności i tworząc z nich skróty (system newsów). Wszytko działało pięknie, zajęła, się stylami podstrony oraz ajaxem, wracam na stronę główną i include nagle nie działa. Inkludowany plik jest w porządku, próbowałam wyświetlić błędy – nic!!!!

    O co chodzi z tym WordPressem, że nagle nie z tego nie z owego coś przestaje działać? Czy on naprawdę nadaje się tylko do bardzo prostych i ubogich stron, ponieważ jak tylko chce się zrobić coś więcej to wszystko się sypie?

    Thread Starter eFKa13

    (@efka13)

    Czy nikt nie umie mi nic poradzić? Czy może zbyt niejasno wytłumaczyłam o co mi chodzi?

Viewing 6 replies - 1 through 6 (of 6 total)