No ciekawe, ale problem już rozwiązałem. Być może ktoś będzie szukał w podobnej sprawie, więc pragnę poinformować, że rozwiązanie dla tego typu problemu znalazłem na tej stronie:
https://porady.wordpressa.pl/jak-naprawic-internal-server-error/
A pomogło dokładnie to:
Uszkodzony, lub zawierający błąd plik .htaccess to jedna z najczęstszych przyczyn wyświetlenia komunikatu Internal Server Error. Zaloguj się na serwer przez swojego klienta FTP i zmień nazwę pliku .htaccess na .htaccess_stary. Plik powinien znajdować się w głównym katalogu WordPressa. Następnie spróbuj przeładować stronę i sprawdź, czy działa. Jeśli tak, zaloguj się do Kokpitu i w zakładce Ustawienia -> Bezpośrednie odnośniki kliknij Zapisz zmiany. To spowoduje wygenerowanie nowego pliku .htaccess.