Wsparcie » Instalacja » Zamiast ogonków mam znaki zapytania

  • Witam
    Posiadam nginx php5 i mysql-5.1.45
    Już któryś raz kompiluje mysql z różnymi opcjami i ciągle nie wiem w czym jest problem 🙁

    ./configure \
      --prefix=/usr \
      --libdir=/usr/lib${LIBDIRSUFFIX} \
      --with-mysqld-user=mysql \
      --with-unix-socket-path=/var/run/mysql/mysql.sock \
      --localstatedir=/var/lib/mysql \
      --mandir=/usr/man \
      --infodir=/usr/info \
      --enable-assembler \
      --without-debug \
      --with-charset=utf8 \
      --with-collation=utf8_general_ci \
      --with-extra-charsets=all \
      --enable-thread-safe-client \
      --with-ssl=/usr \
      --enable-largefile \
      --with-innodb \
      --with-readline \
      --build=$ARCH-slackware-linux

    my.cnf ustawione

    init-connect='SET NAMES utf8'
    #default-character-set=utf8
    #default-collation=utf8_general_ci

    W PHPMyAdmin widzę, że UTF jest ustawione
    * Serwer: MySQL host info: 127.0.0.1 via TCP/IP
    * Wersja serwera: 5.1.45-log
    * Wersja protokołu: 10
    * Użytkownik: xxx@localhost
    * Kodowanie napisów dla MySQL: UTF-8 Unicode (utf8)
    baza wordpressa
    utf8_general_ci
    Mimo wszystko jak tylko wykorzystam polskie znaki zaraz mam ?.
    Jak wejdę do bazy wordpress przez PHPMyAdmin i tam zmienię wpis w tabeli to na blogu widzę polskie znaki.
    Nie wiem w czym jest problem.
    w pliku
    wp-config.php

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    Sprawdzałem już masę opcji łącznie z konwertowaniem.Mimo wszelkich zabiegów mam znaki zapytania zamiast ogonków.

  • The topic ‘Zamiast ogonków mam znaki zapytania’ is closed to new replies.