Wsparcie » Używanie i konfiguracja WordPressa » Usuwanie nieużywanych rozmiarów obrazków

  • Rozwiązany wolnemedia

    (@wolnemedia)


    Zauważyłem, że gdy wgrywam obrazki przez WordPress, tworzy się ich kilka. Co zrobić, by były tylko dwa – obrazek główny (używany w artykule) i miniatura (widoczna na stronie głównej i w kategoriach). Dodatkowe rozmiary nie są mi potrzebne, a zaśmiecają serwer i zużywają powierzchnię dysku serwera.

    Co zrobić by:

    1. Usunąć z poziomu wordpressu wgrane już obrazki w rozmiarach, których nie używam (nie chcę robić przez ftp, by czegoś potrzebnego nie skasować).

    2. Ustawić w wordpressie by wgrywał obrazek pierwotny i miniaturę (lub by wgrywał obrazek pierwotny skalując go do 700 pikseli szerokości) i miniaturę.

    Strona przy której potrzebuję pomocy: [zaloguj się aby zobaczyć ten link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Ile dokładnie tworzy się tych obrazków ?. Czy wordpress jest zaktualizowany do najnowszej wersji ?.

    Mam najnowszą wersję. Tworzy się aż 6 obrazków, choć korzystam tylko z 2.

    Takie mi się tworzą:
    1. normalny obrazek wgrany na serwer (nie używam, chyba że jest mniejszy od 700x)
    2. 150×150 (nie używam)
    3. 300x… (nie używam, ale WP potrzebuje tego jako podglądu miniatury w edycji wpisu)
    4. 768x… (nie używam)
    5. 700x… (używam w artykułach)
    6. 750x… (nie używam)

    To strasznie zaśmieca serwer i zżera pamięć na serwerze. Objętościowo obrazek mający na starcie 50 kb, zajmuje na serwerze z klonami ok. 150 kb.

    Używam też wtyczki Smush do zmniejszania wielkości obrazków. Dobrze byłoby zablokować jakoś tworzenie 150x, 768x, 750x i oryginalnych obrazków jeśli są większe od 700x.

    Dobrze by było, gdyby zbędne obrazki się nie tworzyły, lub można było jakąś wtyczką usunąć hurtem te rozmiary obrazków, które nie są używane we wpisach.

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Dziwne. A czy to czasem nie jakaś wtyczka tworzy tyle tych grafik ?. Albo szablon ?. Bo wordpress sam z siebie nie widziałem nigdy by cos takiego robił, a na nie jednej stronie już z nim pracowałem i pracuję.

    Wyłącz wtyczki odpowiedzialne za foto i dodaj testowo grafiki we wpisie, zobacz czy czasem któraś nei jest odpowiedzialna za to.

    Włącz inny szablon i spróbuj dodać. Potem przełączysz.

    Daj znać,
    pozdrawiam

    Wyłączyłem WSZYSTKIE wtyczki i dodałem obrazek w szablonie Alizee (który mam). Rozmnożył się na 6 plików.

    Włączyłem wtyczki i zmieniłem szablon na standardowy Twenty Nineteen i wgrałem obrazek. Znów rozmnożył się na 6 plików.

    Wyłączyłem wszystkie wtyczki i zmieniłem szablon na Aweken. Wgrałem obrazek i znów się rozmnożył się, ale tym razem o 2 więcej, czyli 8.

    Włączyłem standardowy szablon Twenty Sixteen i wgrałem ten sam obrazek co w Aweken. Rozmnożył się 6 razy (a nie 8).

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Dodatkowo ten sam obrazek na innym wordpressie z bardzo starym szablonem sprzed ok. 7 lat – tam rozmnożył się obrazek x 5, ale z innymi szerokościami (normalny, 90×90, 340x, 600x, 768x). Miniatury są tam wielkości 90×90.

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Na razie usuwam automatycznie nieużywane rozmiary obrazków wtyczką Force Regenerate Thumbnails. Ale nie usuwa oryginalnych obrazków, a jedynie 750x, i 768x. Ale i tak widać znaczną różnicę – w folderze z plikami graficznymi z lutego, w którym było 61 MB po użyciu wtyczki jest teraz 44 MB. To pokazuje, jak WordPress (lub szablon) śmieci.

    Dobrze byłoby jeszcze automatycznie kasować pliki oryginalne, za wyjątkiem tych co są mniejsze niż 700x (bo dla nich 700x i większe się nie tworzą).

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Sprawdź plik motywu functions.php,
    Aby edytować kod z pliku motywu, należy przejść do Wygląd »Edytor .
    Edytuj swój plik functions.php.

    Musisz usunąć kilka linii kodu z tego pliku, który reprezentuje domyślne rozmiary obrazu. Może wyglądać podobnie do tego kodu poniżej:

    set_post_thumbnail_size( 1200, 9999 );
    add_image_size( 'homepage-thumb', 220, 180, true ); 

    (pamiętaj o backupie)

    W tym kodzie, dwie funkcje set_post_thumbnail_size i add_image_size pozwalają twojemu motywowi WordPress generować dodatkowe rozmiary obrazu. Usunięcie kodu sprawi, że twój motyw nie doda więcej zdjęć w WordPress.

    Sprawdź tez Ustawienia -> Media co tam masz ustawione

    Dzięki. To tam miałem ustawione 750x.

    add_theme_support( ‚post-thumbnails’ );
    add_image_size(‚alizee-thumb’, 750);

    Zmieniłem na 700, bo ten rozmiar i tak potrzebuję. Usunąć nie mogę, bo by mi zniknął podgląd miniatury we wpisie.

    W ustawieniach „Mediów” miałem ustawione 150, 300 i 700. Zmniejszyłem sobie na 90x (miniatury) i 0x (średnie), więc trochę miejsca się zaoszczędzi.

    Nadal jednak automatycznie tworzą się rozmiary 768x. Włączona wtyczka Force Regenerate Thumbnails kasuje je automatycznie przy wgrywaniu, ale gdzieś te 768x siedzi (i wtyczka ta nie kasuje oryginalnych obrazków, bo to opcja tylko w wersji Pro). Jakby dało się to odkryć, wtedy wtyczkę mógłbym wyłączyć (im mniej wtyczek tym lepiej).

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    W sumie z Twoją pomocą, za którą dziękuję, problem rozwiązany.

    Wywaliłem
    add_image_size(‚alizee-thumb’, 750); z szablonu strony

    Ustawiłem miniatury na 90×90 a w średnich i wielki obrazkach 0x0.

    Uruchomiłem wtyczkę Force Regenerate Thumbnails i pozbyłem się wszystkich śmieci.

    Do tego używam wtyczki Smush, która automatycznie zmniejsza wielkości kb plików przy wgrywaniu.

    Teraz folder, który miał 50 MB ma tylko 23 MB.

    Szkoda, że nie da się automatycznie zmieniać szerokości pliku wgrywanego, ale będę musiał pamiętać by przed wgraniem obrazka ręcznie go wyedytować na 700 pikseli. Będę szukał jeszcze jakiejś wtyczki do zmiany szerokości obrazka podczas wgrywania z automatycznym usuwaniem większych plików.

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    W ustawieniach mediów dając 0 duplikaty nie powinny się tworzyć dla danego rozmiaru.

    Spróbuj przez Total Commander’a przeszukać pliki strony pod kątem frazy 768px lub po prostu 768. Stawiam że to motyw generuje.

    Tak, zauważyłem, że jak jest 0 w ustawieniach mediów to się nie tworzą. Te 768 poszukam w szablonie, jak radzisz. Gdzieś to musi siedzieć.

    Wtyczka Smush pozwala automatycznie przy wgrywaniu zmieniać pliki większe niż 700 pikseli na 700 (ustawia się maksymalną szerokość i wysokość). Pokazuje też, że gdzieś w ustawieniach jest 768 (bo pokazują się opcje, które rozmiary optymalizować).

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Znalazłem 3 pliki css w których są rozmiary 768 po kilka razy. Nie wiem jednak, który odpowiada za obrazki. Może mógłbym Cię prosić abyś zerknął i wskazał właściwy kod? Nie chcę czegoś spieprzyć.

    https://jupi-tupi.pl/css.zip

    Znalazłem .img-thumbnail ale z wielkością max-width: 100%. Więc 768px wczytywany musi być z innej linijce, które te 100% czyta.

    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.
    • Ta odpowiedź została zmodyfikowana 6 miesięcy temu przez  wolnemedia.

    Może warto spróbować z tą wtyczką:
    https://wordpress.org/plugins/disable-responsive-images-complete/

    obrazy medium_large size 768 mają ten rozmiar, którego chcesz się pozbyć

    Przed zmianami zalecam zgrać bazę danych i pliki z hostingu na komputer.

    Dziękuję! Pomogło! Twoja wtyczka zablokowała tworzenie rozmiaru 768.

    Podsumowując rozwiązanie problemu:

    1. Twoje rady ws. ustawień w Media w wordpressie + wtyczka Disable Responsive Images Complete + wtyczka Smush do optymalizacji obrazków, rozwiązały problemy.

    2. Wtyczka Force Regenerate Thumbnails usunęła zbędne rozmiary nieużywanych obrazków.

    Teraz tworzą się tylko miniaturki i zwykły obrazek zmniejszany automatycznie do 700px prze Smush (Smush też kompresuje obrazki zmniejszając ich wagę przy zachowaniu jakości). I mam na serwerze tylko 2 małe pliki.

    DZIĘKI!

    🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Usuwanie nieużywanych rozmiarów obrazków’ is closed to new replies.