Wsparcie » Zaawansowane » the_excerpt() – Nie działa

  • Pomimo tego że strona podzielona jest za pomocą tagu <!–more–> to funkcja the_excerpt() wyśietla wszystko co jest przed i po tagiem <!–more–>

    Czyli dla strony z zawartością

    TEST PRZED
    <!–more–>
    TEST PO

    Wynik powinien być:
    TEST PRZED

    a jest:
    TEST PRZED
    TEST PO

    Czyli nie uwzględnia podziału. Co ciekawe na innych stronach działa… Druga sprawa że ta strona jest angielska i tu używam wtyczki PolyLang

    Proszę o pomoc jak zmusić the_excerpt() do prawidłowego działania…

    • This topic was modified 4 years, 7 months temu by baholeoko.
    • This topic was modified 4 years, 7 months temu by baholeoko.
    • This topic was modified 4 years, 7 months temu by baholeoko.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Wstawiasz znacznik przyciskiem z belki (Shift+Alt+T) czy wpisujesz ręcznie?

    Thread Starter baholeoko

    (@baholeoko)

    W obu przypadkach testowałem i wstawiałem z belki oraz pisałem z palca
    jest to dokładnie ten znacznik:

    <!- -more- ->

    Efakt podobny czyli nie działa… Zmieniłem tą stronę na PL też nie działa. Jeszcze coś czytałem, że strona nie może być stroną główną, ale do końca nie wiem co o tym decyduje…

    • Ta odpowiedź została zmodyfikowana 4 years, 7 months temu przez baholeoko.
    • Ta odpowiedź została zmodyfikowana 4 years, 7 months temu przez baholeoko.
    • Ta odpowiedź została zmodyfikowana 4 years, 7 months temu przez baholeoko.

    Cześć,
    sposób wyświetlania posta i reagowania obsługi excerpta można zmienić, więc zakładam, że twój motyw albo któraś z wtyczek podpina się pod hook get_the_excerpt albo the_excerpt

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘the_excerpt() – Nie działa’ is closed to new replies.