Wsparcie » Zaawansowane » Server OVH, a polskie znaki

  • Witam serdecznie,

    Dziś chciałem publikować stronę na serwerze docelowym (ovh).
    Napotkałem problem, który mi to uniemożliwił.
    Kombinowałem prawie od rana ale nie znalazłem odpowiedzi.

    Dla informacji, przenosiłem już na różne serwery około 20 stron opartych na wordpressie.

    Standardowo export bazy, edycja url, tak jak zawsze się to robi.
    Import bazy, upload plików, zmiana w pliku wp-config.

    Uruchamiam stronę, patrzę, brakuje polskich znaków a do tego spora część custom-fieldów nie działa. Pomyślałem, że coś z kodowaniem bazy, ale w phpmyadmin wszystko wyglądało ok, ale dla pewności testowałem różne kodowania: utf8_general_ci czy utf8_polish_ci. Na stronie żadnych efektów.

    To stwierdziłem, że spróbuje na zewnętrznej bazie gdzie strona działała poprawnie. Niestety efekt był ten sam.

    Dla testu postanowiłem tą samą stronę wgrać na inny serwer, tym razem hekko. Baza identycznie wgrana jak na OVH tylko oczywiście inny url strony.
    Po prostu identycznie wdrożenie jak robiłem tam.
    Po tej operacji włączam i wszystko działa jak należy! Polskie znaki działają, i custom fieldy również.
    (zewnętrzna baza z której chciałem połączyć wordpressa na ovh też właśnie była na hekko)

    Strona na hekko: http://tracking.at-art.pl/smart/
    Strona na ovh: http://smarttrader.pl/web2015/

    W panelu nie widać większości treści wpisów / stron (mimo to są widoczne na stornie). Niektóre custom fieldy działają, a innych w ogóle nie widać.

    Nie mam pojęcia co z tym mam nie tak. Proszę o pomoc

Viewing 4 replies - 1 through 4 (of 4 total)
  • jakie wersje php i mysql’a masz na hekko, a jakie na ovh?
    Przenieś bazę korzystając z https://wordpress.org/plugins/wp-migrate-db/

    Thread Starter atart

    (@atart)

    Przeniosłem bazę tą wtyczką. Dla pewności na nowo wgrałem wszystkie pliki.
    Efekt ten sam http://smarttrader.pl/web2/

    Wersje MySQL na obu serwarach 5.5

    Wersje php
    OVH: 5.4.38
    hekko: 5.3.29

    mehowq

    (@mehowq)

    Witam,

    Mam dokladnie ten sam problem z OVH :/ atart, dales rade go rozwiazac?

    mehowq

    (@mehowq)

    OK a wiec po kilku godzinach poszukiwan uzylem WP Migrate DB:
    Usunalem reguly Find and Replace i w advanced options odznaczylem Replace GUIDs. Po przekonwertowaniu tabele ktore byly na utf8mb4 sa na utf8 dlatego tez trzeba ustawic w pliku wp-config.php define(’DB_CHARSET’, 'utf8′);
    na razie wszystko dziala ok 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Temat ‘Server OVH, a polskie znaki’ jest zamknięty na nowe odpowiedzi.