Wsparcie » Używanie i konfiguracja WordPressa » Przeniesienie WP na local

  • Dzień dobry,
    Chcę spróbować do istniejącej witryny Wordpresowej dołożyć tłumaczenie w kilku językach. Chcę wykorzystać bezpłatną wtyczkę Polylang. Nie chce próbować tego na „żywym organizmie” dlatego chciałbym przenieść tę stronę na komputer lokalnie.
    Zainstalowałem WAMP, ściągnąłem przez ftp całą zawartość witryny z serwera, wtyczką „WP Database Backup” zrobiłem kopię bazy (niestety nie mam dostępu ani do directAdmin czy cPanel na serwerze 🙁 ).
    Ściągniętą zawartość strony z serwera skopiowałem do WAMP-a (WAMP/www/moj_katalog). Poprzez phpMyAdmin (4.9.3) WAMP-a założyłem bazę o nazwie pobranej z znaleziona w wp-config.php. Zaimportowałem do niej ściągniętą bazę z serwera, dodałem użytkownika (również dane z wp-config.php), zmieniłem wpisy w wp_options „siteurl” i „home” ma http://localhost/moj_katalg.
    Niestety kiedy próbuje wejść w przeglądarce na localhost/moj_katalg pojawia się błąd „Ta witryna jest nieosiągalna. Serwer localhost odrzucił połączenie. ERR_CONNECTION_REFUSED”. Mogę się dostać do localhost/moj_katalog/wp-admin ale na tym kończy się moja wiedza, jak można uruchomić kopie strony pobranej z serwera na komputerze lokalnym.
    Trochę się rozpisałem, ale chciałem przedstawić istniejący stan rzeczy i prosić o ewentualne wskazówki i rady, jak mogę uruchomić witrynę (pozbyć się ERR_CONNECTION_REFUSED) lokalnie.
    Z góry dziękuję za chęć pokierowania mnie 🙂
    Z poważaniem skom27

Viewing 3 replies - 1 through 3 (of 3 total)
  • A włączyłeś serwer wampa? Ikonka musi się świecić na zielono.

    Thread Starter skom27

    (@skom27)

    Oczywiście że włączone :). Świeci na zielono 🙂
    Cały czas ładuje jako https :(. „siteurl” i „home” w wp_options bazy próbowałem i jako „http://localhost/..” i jako „https://localhost/..” jednak bez pozytywnych rezultatów 🙁
    Nie mogę zmusić żeby wejść na http a nie https (inne witryny na WAMP działają OK jak http, a ta jedna „zawzięta” 🙁

    • Ta odpowiedź została zmodyfikowana 2 months, 3 weeks temu przez skom27.
    • Ta odpowiedź została zmodyfikowana 2 months, 3 weeks temu przez skom27.

    Czy po wejściu na adres http://localhost/ pojawia ci się strona wampa?
    Czy adresy z kolumny Tools działają i np pokazuje ci się php info:

    phpinfo()
    xdebug_info()
    PhpSysInfo
    Add a Virtual Host

    Czy adresy aliasy jak np phpMyAdmni, Adminer (z menu po kliknięciu na ikonke w Tray’u) działają?
    PhpMyAdmin 5.1.1 itd?

Viewing 3 replies - 1 through 3 (of 3 total)