Wsparcie » Używanie i konfiguracja WordPressa » Problemy z WP po aktualizacji

  • Czy ktoś tu jeszcze pomaga na tym forum?

    Zaktualizowałam WP do tej najnowszej wersji, włączyłam wszystkie wtyczki.
    Ale pojawił się problem z szablonem:

    Zamiast kilku podstron na stronie, pojawia się tylko pierwsza. Reszty nie ma, pomimo tego że widać je w kokpicie.
    To jest paginacja strony?

    Nie wiem co robić. Przed aktualizacją wszystko pięknie się wyświetlało, pomimo tego że wcześniejsza wersja WP miała 6 lat, teraz widać tylko jedną podstronę. Nie ma „Motywy” w wyglądzie, ale to najmniejszy problem.

    No i kokpit długo się ładuje !!! Ciężko coś zrobić, bo trzeba czekać wieczność.

Viewing 15 replies - 61 through 75 (of 81 total)
  • To czyli wychodzi na to, że strona w ogóle nie powinna być aktualizowana. Pierwsza aktualizacja i problem.

    no może być i tak…

    No ale niezaktualizowana strona = ryzyko ataku hakerów
    zaktualizowana, ale z błędem..

    i co robić?
    chyba że błąd jest do naprawienia..

    Musisz w każdym z tych wypadków zatrudnić developera… Chyba że masz znajomego 🙂

    Jak zainstalujesz jakiś Wordfence, to on będzie starał się blokować wejścia na stronę mające za cel zhakowanie strony. nie ma jednak idealnych rozwiązań…

    A da się naprawić tę drobną usterkę w WP?

    To nie musi być drobna usterka, czytając temat wyraźnie na początku autor strony się wyraził:

    Strona została stworzona 6 lat temu…
    Z uwagi na jej specyfikę i wiek aktualizacja jest niewykonalna dla laika.

    – oznacza to, że oprócz tego, że strona sama w sobie jest stara(automatyczne aktualizacje z bardzo starych wersji WP bardzo często powodują problemy), to jeszcze posiada rozwiązania autorskie.

    Zbierz fundusze i poszukaj firmy, która przeprogramuje Tobie stronę do najnowszego wordpressa, zaaktualizuje skrypty i przygotuje ją tak, aby przy aktualizacjach nie było problemów z wewnętrzną integracją. Obecnie wordpress jest na tyle rozbudowany, że nie powinno być podobnych problemów, jeśli zleceniobiorca odpowiednio wykona stronę.

    Następnie ustawić na serwerze php przynajmniej w wersji 5.3(najlepiej 5.6) i zabezpieczyć odpowiednio samą stronę jakąś wtyczką. Może być Wordfence lub Sucuri, choć te raczej są ciężkie – proponuję rozejrzeć się za lżejszymi alternatywami.

    CMSy mają to do siebie, że niestety wypada trzeba je aktualizować.

    Widziałem stronę i nie wspominałaś, że masz zmienione adresy do plików np. motywu

    www.**********.pl/template/css/structure.css
    www.**********.pl/template/js/scripts.js
    itp

    Ja bym postawił na subdomenie WP z tym motywem (szablon to zupełnie co innego), a dokładniej jego ostatnią wersją, zmienił stare funkcje na nowe, import zawartości na czystą bazę i teoretycznie powinno pójść bez problemów – 6 lat temu to ja zaczynałem przygodę z WP i wiem, że po przegapieniu 2 czy 3 aktualizacji miałem problem z motywem podstawowym więc po tylu latach może się okazać że lepiej jest zbudować to od zera niż naprawiać.

    Wonderfance oprócz bałaganu w bazie i dłuższego ładowania stron+kokpitu da ci złudne poczucie bezpieczeństwa tyle co napisz „jesteś bezpieczna”… na jednym z WordUpów pokazał chyba Dziudek jak z pomocą kilku linijek zawirusowana strona była zawsze bezpieczna 🙂

    Mateusz Jaworowicz
    mateusz@jaworowi.cz

    Posts 2 Posts………………
    w tym być może tkwi problem. Ten plugin odpowiada za connected.

    Próba aktualizacji tego pluginu do wyższej wersji spowodowało rozsypkę strony. Jak to możliwe?

    Teraz jest wersja 0.2. a może coś w kodzie trzeba zmienić?

    Tyle błędów pokazał debug:

    Strict Standards: Non-static method PageNavi_Core::init() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/wp-pagenavi/wp-pagenavi.php on line 241

    Strict Standards: Declaration of Taxonomy_Drill_Down_Widget::init() should be compatible with scbWidget::init($class, $file = ”, $base = ”) in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/widget.php on line 0

    Strict Standards: Declaration of QMT_List_Walker::start_el() should be compatible with Walker_Category::start_el(&$output, $category, $depth = 0, $args = Array, $id = 0) in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/widget.php on line 0

    Strict Standards: Declaration of QMT_Dropdown_Walker::start_el() should be compatible with Walker_CategoryDropdown::start_el(&$output, $category, $depth = 0, $args = Array, $id = 0) in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/widget.php on line 0

    Strict Standards: Non-static method QMT_Query::init() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/query-multiple-taxonomies.php on line 39

    Strict Standards: Non-static method QMT_Template::init() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/query-multiple-taxonomies.php on line 40

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method QMT_Query::pre_get_posts() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-includes/plugin.php on line 546

    Strict Standards: Non-static method QMT_Query::find_query() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/core.php on line 23

    Strict Standards: Non-static method QMT_Query::is_regular_query() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/query-multiple-taxonomies/core.php on line 70

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method QMT_Query::posts_where() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-includes/plugin.php on line 247

    Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method QMT_Template::template() should not be called statically in /home/xxx/domains/xxx.pl/public_html/wp-includes/plugin.php on line 470

    Notice: Undefined index: post_type in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/simple-custom-post-type-archives/simple-custom-post-type-archives.php on line 72

    Notice: Undefined index: name in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/simple-custom-post-type-archives/simple-custom-post-type-archives.php on line 74

    Notice: Trying to get property of non-object in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/simple-custom-post-type-archives/simple-custom-post-type-archives.php on line 35

    Notice: Trying to get property of non-object in /home/xxx/domains/xxx.pl/public_html/wp-content/plugins/simple-custom-post-type-archives/simple-custom-post-type-archives.php on line 35

    ????

    Tutaj jest pracy na kilka godzin min 2 – wątpie, aby ktoś to na forum powiedział jak ci zrobiąc nie widząc:

    * jakie wtyczki i wersje
    * jaki motyw

    Nawet znając adres strony nie jestem w stanie tego określić bo jest strona tak „zabezpieczona”

    jaworowi.cz, w jaki sposób można się z tobą skontaktować?

    mateusz@jaworowi.cz
    Lub prośba o telefon (11-1 w nocy)
    https://jaworowi.cz/ratunku.html

    Ale czy te 15 błędów da się jakoś naprawić? Tak mniej więcej?
    I czy wtedy funkcja c. będzie znowu działała?

    Bo jeśli marne szanse, to wracamy do starej wersji WP. Tej, na której wszystko działało.

    Wszystko się da kwestia czasu, budżetu i podejścia 🙂

    Tak naprawdę musiałbym to po prostu zobaczyć od środka – mam za mało danych (m.in. tych o których pisałem powyżej).

    Aktualizacja wstecz to dość ryzykowne bo w końcu przyjdzie dzień kiedy coś Tobie wlezie na te instalacje… odwirusowanie 150-197/h taniej to naprawiać.

Viewing 15 replies - 61 through 75 (of 81 total)
  • The topic ‘Problemy z WP po aktualizacji’ is closed to new replies.