Wsparcie » Motywy » Problem z wyśrodkowaniem nagłówka w szablonie z ThemeForest

  • Rozwiązany Vanillamadness

    (@vanillamadness)


    Witam.
    Tak jak w temacie, nie potrafię centralnie umieścić grafiki, która ma być nagłówkiem strony. Podaję do niej adres: http://www.vanillamadness.com/ Jakiego rozmiaru bym nie użyła i jakiej opcji w ustawieniach nagłówka nie wybrała, zawsze ląduje po lewej stronie i może mieć maksymalnie taki jak na stronie rozmiar, mimo że oryginalnie wygląda tak: http://www.vanillamadness.com/wp-content/uploads/2014/06/BEST-1.png
    To może być wina tego, że szablon, którego używam (Newsright z ThemeForest) zakłada, że po prawej stronie znajdować ma się banner, z którego aktualnie nie korzystam. Chciałabym jednak, żeby grafika była umieszczona centralnie i w rozmiarze takim jaki rzeczywiście ma. Dodaję kod header.php Czy może ktoś mi pomóc?

    <?php global $smof_data; ?><!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <title><?php

    if(is_home()) {
    bloginfo(„name”); echo ” | „; bloginfo(„description”);
    } else {
    echo wp_title(” | „, false, ‚right’); bloginfo(„name”);
    }

    ?></title>
    <meta name=”viewport” content=”width=device-width, initial-scale=1.0″>
    <meta charset=”<?php bloginfo( ‚charset’ ); ?>” />
    <link rel=”pingback” href=”<?php bloginfo( ‚pingback_url’ ); ?>” />
    <?php

    /* popup comment */
    if ( is_singular() && get_option( ‚thread_comments’ ) ) {
    wp_enqueue_script( ‚comment-reply’ );
    }

    /* show wp head */
    wp_head();
    ?>
    <!–[if lte IE 9]>
    <link rel=’stylesheet’ id=’font-awesome-ie7′ href='<?php echo get_template_directory_uri(); ?>/css/font-awesome-ie7.min.css’ type=’text/css’ media=’all’ />
    <link rel=’stylesheet’ id=’ie-css’ href='<?php echo get_template_directory_uri(); ?>/css/ie.css’ type=’text/css’ media=’all’ />
    <script src=”//html5shim.googlecode.com/svn/trunk/html5.js”></script>
    <![endif]–>
    </head>
    <body <?php body_class(); ?> id=”top” >
    <div <?php mtc_boxed_class(); ?>>
    <header itemscope itemtype=”http://schema.org/WPHeader”&gt;
    <div class=”wrapper _header_top”>
    <div class=”container”>
    <div class=”row-fluid”>
    <div class=”span12″>
    <div class=”header_top”>
    <div class=”topnav_toggle”></div>
    <?php wp_nav_menu( array( ‚theme_location’ => ‚top-menu’,
    ‚menu’ => ”,
    ‚container’ => ”,
    ‚container_class’ => ”,
    ‚container_id’ => ‚top-menu’,
    ‚menu_class’ => ‚nav’,
    ‚menu_id’ => ”,
    ‚echo’ => true,
    ‚fallback_cb’ => ‚wp_page_menu’,
    ‚before’ => ”,
    ‚after’ => ”,
    ‚link_before’ => ”,
    ‚link_after’ => ”,
    ‚items_wrap’ => ‚<ul id=”%1$s” class=”%2$s main-menu”>%3$s’,
    ‚depth’ => 0,
    ‚walker’ => ”
    ));

    ?>

    <form method=”get” id=”searchform_top” action=”<?php echo home_url( ‚/’ ); ?>”>
    <input type=”text” class=”newsright-search” name=”s” id=”s_top” value=”” placeholder=”SEARCH…” />
    </form>

    </div>
    </div>
    </div>
    </div>
    </div><!– end _header_top –>

    <div class=”wrapper _header”>
    <div class=”container”>
    <div class=”row-fluid”>
    <div class=”span12 header”>
    <h1 class=”logo”>
    ” title=”<?php bloginfo(„name”);?>”>
    <?php if(!empty($smof_data[‚logo’])) :?>
    <img src=”<?php echo $smof_data[‚logo’];?>” alt=”Logo” />
    <?php else :?>
    <img src=”<?php get_template_directory_uri();;?>/img/logo.png” alt=”Logo” />
    <?php endif;?>

    </h1>
    <?php

    /* Banner Header */
    if($smof_data[‚switch_ad_header’]) {

    $class_size_banner = (468 == $smof_data[‚ad_header_size’]) ? ‚ size468’ :” ; ?>
    <div class=”header_ad<?php echo $class_size_banner; ?>”>
    <?php if(!empty($smof_data[‚ad_header_img’])) :?>
    „><img src=”<?php echo $smof_data[‚ad_header_img’];?>” alt=”” />
    <?php else :?>
    <?php echo $smof_data[‚ad_header_code’];?>
    <?php endif;?>
    </div><?php
    }

    ?>
    </div>
    </div>
    </div>
    </div>

    <div class=”wrapper _main_navigation”>
    <div class=”container main_navigation”>
    <div class=”row-fluid”>
    <div class=”span12″><?php
    wp_nav_menu( array( ‚theme_location’ => ‚main-nav’,
    ‚menu’ => ”,
    ‚container’ => ‚nav’,
    ‚container_class’ => ‚main-navigation’,
    ‚container_id’ => ‚main-navigation’,
    ‚menu_class’ => ‚nav’,
    ‚menu_id’ => ”,
    ‚echo’ => true,
    ‚fallback_cb’ => ‚bzine_default_menu’,
    ‚before’ => ”,
    ‚after’ => ”,
    ‚link_before’ => ”,
    ‚link_after’ => ”,
    ‚items_wrap’ => ‚<ul id=”%1$s” class=”%2$s main-menu”>%3$s’,
    ‚depth’ => 0,
    ‚walker’ => new Mtc_Nav_Menu_Walker
    ));
    ?>
    <div class=”smallmenu”><div id=”dropmenu”></div></div>
    </div>
    </div><?php mtc_btn_show_cart(); ?>
    </div><!– end main_navigation –>
    </div>
    </header><!– END header–>

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problem z wyśrodkowaniem nagłówka w szablonie z ThemeForest’ is closed to new replies.