Wsparcie » Motywy » Problem z włączeniem/przełączeniem motywu

  • Witam, pewnie pytanie jest banalne, ale dopiero zaczynam „współpracę” z wordpressem i mam problem z którym nie mogę sobie poradzić – a mianowicie nie mogę przełączyć motywu na mojej stronie.. .
    Aktualizują się informacje tekstowe, ale cały czas na motywie, który narzucił WP przy instalacji. Wybrany przeze mnie motyw widoczny jest natomiast w momencie włączenia opcji personalizacji… i nigdzie więcej. Nie zmieniają się również poszczególne funkcje np. kolejność w menu. Widzę w necie, że we wcześniejszych wersjach było coś takiego jak „Zainstaluj motyw/prześlij na serwer”. Ja tych opcji u siebie nie widzę, ale z drugiej strony przy motywie pokazuje się info „aktywny”, no i na serwerze ftp również jest folder z jego nazwą i elementami…

    Dodatkowo zaznaczam, że sytuacja dot. wszystkich motywów. Widać tylko ten „z automatu od WP”, żadne inne nie są widoczne.

    Czy ktoś mógłby wskazać mi drogę? co powinnam zrobić dalej? ewentualnie gdzie popełniam błąd?

Viewing 5 replies - 1 through 5 (of 5 total)
  • pliki szablonu powinny znajdować się w wp-content/themes/nazwa_szablonu
    no i powinny być kompletne w pliki, jeśli przy zmianie dalej nie chce załapać nowego motywu wejdź w phpmyadmin (bazy danych – mysql)

    wybierasz tabele wp_options, przechodzisz na 2 stronę (okolo 43 rekord) i masz takie cuś template i stylesheet w nich powinna być nazwa folderu szablonu, tego który chcesz żeby był widoczny na stronie.

    Dziękuję za odpowiedź. Niestety to nie to. Sprawdziłam na serwerze – wp-content/… – pliki są. Podobnie w bazie danych – zarówno template, jak i stylesheet pokazuje wybrany przez mnie motyw. Za każdym razem gdy zmieniam w wp na inny – wszystko ładnie podmienia się w bazie danych – zmiany są od razu widoczne. Niestety tylko tu… Na samej stronie nadal nic to nie zmienia.

    Może jakiś inny pomysł?

    wywal całego wordpress’a oprócz config.php i folderu wp-content, jeśli się naprawi to wina wordpress’a, jeśli nie wywal cały content i graj z oryginalnego, jeśli sie naprawi wina szablonów, jeśli nie to reinstalacja bazy mysql.

    jeśli dobrze zrozumiałam radę to i to nie pomaga. Kasując te pliki wywala się cały wordpress. Baza mySql tez chyba też nie jest problem, bo tak naprawdę dziś wszystko tam wyrzucałam/czyściłam i na nowo instalowałam wp.

    A może jest jeszcze jakaś możliwość?
    Może jakaś „oczywista oczywistość”, bo cały czas mam wrażenie, że zapomniałam o czymś podstawowym… A z drugiej strony nie wprowadziłam chyba tyle zmian, by mogły pojawić się problemy aż tak „głęboko”, w skryptach/bazach/itd…

    Dziś instalując i konfigurując szablon klientowi spotkałem się z problemem przełączania szablonów. Dokładnie był problem na hostingu OVH.

    Do pliku wp-config.php jest automatycznie dopisywane:
    define(’WP_CACHE', true); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', ABSPATH.’/wp-content/plugins/wp-super-cache/' ); //Added by WP-Cache Manager

    Wyłączyłem plugin WP Super Cache i usunąłem 2 linijki kodu z pliku wp-config.php. Wszystko działa jak należy.

    Pozdrawiam

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem z włączeniem/przełączeniem motywu’ is closed to new replies.