Wsparcie » Motywy » Problem z szablonem (chyba)

  • Witam, jestem laikiem i problem może okazać się prosty ale nie dla mnie. Proszę o pomoc jeśli ktoś zna rozwiązanie. Na mojej stronie cały czas pojawia się komunikat: Deprecated: Korzystanie z jquery-slick uznawane jest za przestarzałe od wersji 2.7.0! Zamiast tego użyj Swiper. in /home/etna/domains/etna.waw.pl/public_html/wp-includes/functions.php on line 5051 i Notice: Undefined variable: svg_html in /home/etna/domains/etna.waw.pl/public_html/wp-content/themes/canteen/header.php on line 71 Próbowałem szukać w Google i coś zmieniać/sprawdzać ale żadnych efektów. Może ktoś ma rozwiązanie i chęć prostego wytłumaczenia mi co i jak?

    Strona przy której potrzebuję pomocy: [zaloguj się aby zobaczyć ten link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Komunikat mówi o tym, że:

    Korzystanie z jquery-slick uznawane jest za przestarzałe od wersji 2.7.0! Zamiast tego użyj Swiper

    i odnosi się do jakiegoś miejsca w twoim motywie, w pliku header.php w linii 71.
    Co tam jest?

    Thread Starter wojteketna

    (@wojteketna)

    To może być to?
    } else if ($canteen_preload == 'show_all’) {echo wp_kses($svg_html,$allow_html); }

    Coś takiego jest pod numerem 71 ale dla mnie to czarna magia o co tu chodzi.

    Ale z wycinka mi nic. Cały plik pokaż, albo daj link do źródeł.

    Thread Starter wojteketna

    (@wojteketna)

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset=”<?php bloginfo(’charset’); ?>”>
    <link rel=”profile” href=”//gmpg.org/xfn/11″ />
    <meta name=”viewport” content=”width=device-width, initial-scale=1″ >

    <?php wp_head(); ?>
    </head>

    <body <?php body_class(); ?>>
    <?php wp_body_open(); ?>
    <div class=”cursor”></div>

    <?php if ( class_exists(’ReduxFrameworkPlugin’) ) :
    if (canteen_option( 'canteen_preloader_set’)) :
    $canteen_preload = canteen_option( 'canteen_preloader_set’ );
    $canteen_preloader_type = canteen_option( 'canteen_preloader_type’ );
    $canteen_svg_url = get_template_directory_uri().’/images/loader-svgs’;
    if ( $canteen_preloader_type == „circle” ) {
    $svg_html = '<div class=”pre-loading”><div class=”load-circle”></div></div>’;
    } else if ( $canteen_preloader_type == „animated_logo” ) {
    $svg_html = '<div class=”svg-pre-loading”><div class=”pre-loader”> <object data=”’.$canteen_svg_url.’/canteen_loader.svg” type=”image/svg+xml”></object></div></div>’;
    }
    $allow_html=
    array(
    'div’ => array(
    'class’ => array(),
    ),
    'object’=> array(
    'data’=> array(
    array(
    'svg’ => array(
    'class’ => true,
    'xmlns’ => true,
    'width’ => true,
    'height’ => true,
    'viewbox’ => true,
    'aria-hidden’ => true,
    'role’ => true,
    'focusable’ => true,
    ),
    'path’ => array(
    'fill’ => true,
    'stroke’ => true,
    'stroke-miterlimit’ => true,
    'fill-rule’ => true,
    'd’ => true,
    'transform’ => true,
    'class’ => true,
    'stroke-width’ => true,
    ),
    'polygon’ => array(
    'fill’ => true,
    'fill-rule’ => true,
    'points’ => true,
    'transform’ => true,
    'focusable’ => true,
    ),
    'style’ => array(
    'data-made-with’ => true,
    ),
    ),
    ),
    'type’=> array(),
    ),
    );

    if ($canteen_preload == 'show_home’) { ?>
    <?php if (is_front_page() ){ echo wp_kses($svg_html,$allow_html); }
    } else if ($canteen_preload == 'show_all’) {echo wp_kses($svg_html,$allow_html); }
    endif ;
    endif; ?>

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problem z szablonem (chyba)’ is closed to new replies.