Wsparcie » Używanie i konfiguracja WordPressa » Problem z podstronami

  • Witam serdecznie. Mam problem z linkami do podstron.
    Zrobiłem własny szablon, który zawiera nawigacje , w której odsyłacze są kotwicami. To działa. Jednak potrzebuje jednej podstrony. I tutaj zaczyna się problem. Dodałem odsyłacz do menu, który dla celów testowych ma prowadzić do domyślnej przykładowej strony WP. Po jego kliknięciu w pasku adresowym dopisuje się końcówka „przykładowa-strona” Lecz strona się nie przeładowuje. Cały czas widzę swoją stronę główną. Ktoś wie może gdzie jest problem?
    Dodam, że jak zmienię motyw na któryś z domyślnych to problem nie występuje i strona się przeładowuje.
    Z góry dziękuję za pomoc.
    PS. Jeżeli problem się pojawił proszę o linka do posta. Szukałem, lecz nie wiem nawet jak otagować problem.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Paweł Knapek

    (@adpawl)

    Jeżeli jako adres podałeś: przykladowa-strona, to to dopisze się do wcześniejszego adresu URL.
    Musisz dać: /przykladowa-strona (ze slashem na początku) albo podać pełny adres URL.

    Z kotwicami jest podobnie i też zamiast: #kotwica lub podstrona#kotwica warto zaczynać od ukośnika albo podawać pełny adres URL – inaczej będzie problem z kierowaniem na niewłaściwe lokalizacje czy z doklejkami.

    tylko że w menu link do przykładowej_strony z wp dodałem przez dostosuj menu nawigacji w WP. tam porostu wskazałem tę stronę

    Moderator Paweł Knapek

    (@adpawl)

    To dodaj tą pozycję do menu przez własny odnośnik.

    Niestety ciężko pomóc nie widząc tej strony i bez wglądu w kod motywu.

Viewing 3 replies - 1 through 3 (of 3 total)