Wsparcie » Zaawansowane » Problem z motywem – brak przekierowania /page/2/ w postacg

Viewing 15 replies - 1 through 15 (of 16 total)
  • Wyłącz minifikacje kodu, bo sypie javascripta.
    Jaka wersja motywu? ….czy wszystko poaktualizowane?
    W kodzie nie zauważyłem w tym miejscu, by były jakieś odsyłacze do paginacji …ale czasem googlebot mimo wszystko trafia jakoś pod teoretycznie nieistniejące adresy (czy to sam probuje rózżne kombinacje, czy też przypadkiem). Natomiast faktycznie te adresy tutaj działają, choć domyslnie powinny kierować na adres wpisu.
    Mogły sie przypadkiem permalinki sypnąć.
    -czy nadpisywałeś: Ustawienia >> Bezpośrednie odnośniki >> Zapisz ?

    Thread Starter Hicarian

    (@hicarian)

    @paweł, czy teraz ci się prawidłowo strona wyświetla?

    Wszystko poauktualizowane. Nadpisałem.

    Myślę, że na szybko najlepszym rozwiązaniem byłoby ustawienie w httaccess przekierowania z page/2/ na BEZ, ale tylko dla postów. Czy może znasz taką regułkę?

    Dalej sypie się js, w speed boosterze masz ustawione przenoszenie skryptów do footera – tyle, że przenosi tez bibliotekę jquery, a wcześniej w kodzie masz skrypty na niej bazujące i lipa.
    No i wtyczek nie poaktualizowałeś chyba jeszcze.

    Możesz sprawdzić https://wordpress.stackexchange.com/questions/208760/how-to-disable-content-pagination

    Thread Starter Hicarian

    (@hicarian)

    Paweł,
    Dziękuje za odpowiedź. Wyłączyłem wtyczkę Speed Booster- czy teraz już ci się nic ne sypie?

    Co do linka do stackex, niestety nie działają tzn, probowałem dodac je do function.php motywu, jak i zmienic <?php the_content(); ?> w single.php i dalej mam /page/x/

    Czy masz pomysł na rozwiązanie problemu?

    Thread Starter Hicarian

    (@hicarian)

    Juz wiem, co powoduje problem z błędną paginacją, ale nie wiem jak go rozwiązać. Sprawdziłem, że gdy wybiorę:

    W ustawieniach bezpośrednich

    https://crediteo.pl/przykladowy-wpis/

    To nie ma page/2/

    Jeśli jednak wezmę własny format, który mam od początku, czyli:

    https://crediteo.pl/%category%/%postname%/

    Ponieważ, zależy mi na kategoru w adresie url, to występuje ten błąd. W jaki sposób, mogę to naprawić?

    Jest już znacznie lepiej, ale sypie się coś jeszcze na z jQuery Tablepress.
    natomiast z tego co widzę, to problem z paginacją ustąpił – lipne podstrony przekierowują już do oryginalnego wpisu.

    Thread Starter Hicarian

    (@hicarian)

    Udało mi się odnaleźć funkcę w function.php, którą odpowiadała za posts. Niestety na stronie głównej cały czas generują page/2/

    Czy znasz regułę httaccess, która wymusi przekierowanie z /page/2/ na stronie do strony głównej?

    Szukam czegoś podobnego do, ale nie dla index.php ale dla page/2/

    #strip index.php/* from the URL
    RewriteCond %{THE_REQUEST} ^[^/]*/index\.php/ [NC]
    RewriteRule ^index\.php/(.+) http://%{HTTP_HOST}/$1 [R=301,L,QSA]

    RewriteRule ^page/\d+ / [R=301,L]

    Thread Starter Hicarian

    (@hicarian)

    Paweł, niestety nie działa to przekierowanie.

    Myślałem jeszcze nad zablokowaniem indeksacji przez Google, jeżeli będzie wywołany w adresie page/2/

    <?php
    // get current page we are on. If not set we can assume we are on page 1.
    $paged = (get_query_var(’paged’)) ? get_query_var(’paged’) : 2;
    // are we on page one?
    if(2 == $paged || is_homepage() || is_tag() || is_date() || is_attachment()){
    echo '<meta name=”robots” content=”noindex,follow” />’;
    } ?>

    Niestety, ta regułka działa nawet na stronie głównej =0 , a chciałbym ograniczyć wywołanie jej jedynie na stronie głównej gdy będzie w adresie dodany page/x/

    • Ta odpowiedź została zmodyfikowana 4 years, 6 months temu przez Hicarian.
    • Ta odpowiedź została zmodyfikowana 4 years, 6 months temu przez Hicarian.

    A dobrze tamtą regułkę dodałeś? -bo jak najbardziej działa, sprawdzone.
    Możesz sobie nawet przetestować tutaj https://htaccess.mwl.be/

    Thread Starter Hicarian

    (@hicarian)

    Pawle, dziękuje serdecznie. Źle wstawiłem tę regułkę. Bardzo serdecznie ci dziękuje za pomoc. Temat, uważam za zamknięty 🙂

    Thread Starter Hicarian

    (@hicarian)

    Witaj Pawle,
    Mam jeszcze jedno pytanie/prośbę. Otóż chciałbym przekierować wszystkie adres url z końcówką blabla/feed/ blabla/rss na bez feed i rss:

    https://crediteo.pl/feed/
    na:
    https://crediteo.pl/

    Skorzystałem ze strony, którą mi przedstawiłeś:

    https://htaccess.mwl.be/

    Zastosowałem takie regułki w httaccess:

    RewriteRule ^([^/]+)/([^/]+)/feed/ /$1/$2/ [R=301,L]
    RewriteRule ^([^/]+)/([^/]+)/\d+/feed/ /$1/$2/2/ [R=301,L]
    RewriteRule ^feed/ /$1/ [R=301,L]

    i na:
    https://htaccess.mwl.be/

    Wszystko jest OK.

    Niestety, po dodaniu tych regułek do httaccess, pomimo pozytywnego testu, cały czas wczytuje mi /feed i /rss.

    Rozwiazaniem na prędko jest włączenie wtyczki Disable Feed i użycie opcji redirect. Jednak nie chce korzystać z dodatkowych wtyczek. Czy wiesz, gdzie w httaccess popełniłem błąd?

    Przy okazji, czy nadal ci się wykrzacza layout?

    • Ta odpowiedź została zmodyfikowana 4 years, 6 months temu przez Hicarian.

    https://kinsta.com/knowledgebase/wordpress-disable-rss-feed/
    RewriteRule ^(.*?)feed(.*?)$ / [R=301,L]

    Thread Starter Hicarian

    (@hicarian)

    Dzięki Pawle, ale ta regułka nie działa. Sprobuje sam odnaleźć rozwiązanie.

    Ponownie zapytam, czy aby dobrze dodałeś? – bo dla pewności sprawdziłem i działało.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Temat ‘Problem z motywem – brak przekierowania /page/2/ w postacg’ jest zamknięty na nowe odpowiedzi.