Wsparcie » Używanie i konfiguracja WordPressa » Problem z galerią i jQuery

  • Witam, mam problem z galerią na stronie http://www.pckis.pl
    Gdy ustawiam galerie na 4 kolumny wyświetlają się 3 i 4 plik niżej
    Gdy ustawie galerie na 3 kolumny wyświetlają się 2 i 3 plik niżej.

    (Po update)Kolejny problem to w panelu admina pojawiający się komunikat „blockUI requires jQuery v1.2.3 or later! You using v1.10.2 jedyną wtyczkę jaką posiadam to „jQuery UI Widgets” którą zaktualizowałem do najnowszej wersji.

    Zna ktoś roziązanie tego problemu ??

Viewing 6 replies - 1 through 6 (of 6 total)
  • 1. w pliku style.css dodaj sobie:
    #gallery-1 .gallery-item { width: auto !important; }

    2. ja tam widzę znacznie więcej wtyczek, m.in. jQuery Updater – która może sprawiać nieraz nieprzewidziane problemy.

    Thread Starter kiko89

    (@kiko89)

    Galerii pomogło !! Dziękuje!

    Więc jak sobie poradzić z tym jQuery ?!
    jQuery Updater – zainstalowałem już gdy występował ten problem./Odinstalowałem/

    Szwankuje też wtyczka „All-in-One Calendar by Then.ly”
    Nie działają wszystkie opcje… które niestety są mi potrzebne.

    Thread Starter kiko89

    (@kiko89)

    Wszystkie wtyczki z nazwą jQuery w nazwie mam usunięte lecz problem dalej występuje

    Thread Starter kiko89

    (@kiko89)

    A czy istnieje możliwość Downgradu do poprzedniej wersji wordpressa?

    Moderator amistad18

    (@amistad18)

    W jaki sposób szwankuje Ci wtyczka All-in-One Calendar?
    Jeżeli nadal masz problem z jakimiś konfliktami jQuery, i chciał byś używać wtyczki która wymaga jej nowszej wersji, wtedy musisz wpierw zlokalizować co dołącza jej starszą wersję (stawiam na szablon, ale to też może być wtyczka), i zmienić tam wersję na najnowszą. W szablonie zaczął bym od szukania w pliku functions.php, jak nie będzie to po kolei we wszystkich kolejnych plików do których się odwołuje w kodzie.

    Co do komunikatu, to pojawia się zazwyczaj z winy motywu lub jakiejś wtyczki ładującej starą wersję biblioteki BlockUI.
    Najlepiej taki motyw /lub/ wtyczkę zaktualizować …a jeżeli nie ma dostępnej aktualizacji, zrobić sobie samodzielnie upgrade biblioteki blockUI. nową znajdziesz tutaj: http://malsup.github.io/jquery.blockUI.js

    Zdecydowanie nie polecam obejść pokroju downgrade wordpressa czy nawet jquery.

    A co do wtyczki All-in-One – nie pomogę niestety.
    To straszny koszmarek jest, problemów z nią od groma. Chyba nie bez powodu wtyczka wyleciała z repo wordpressa.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Temat ‘Problem z galerią i jQuery’ jest zamknięty na nowe odpowiedzi.