Wsparcie » Motywy » Problem z czcionką

  • Witam Serdecznie!

    Zakładam właśnie stronę grupy tanecznej. W internecie znalazłem bardzo fajny styl, jednak brak w nim polskich znaków. O ile w innym stylu na wcześniejszej stronie którą robiłem, poradziłem sobie doskonale – tak z tym mam problem. Proszę o pomoc. Link do strony: http://www.szczakowianka.pl/testowanie/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Ale z czym dokładnie masz problem?

    Tutaj masz przecież plik definiujący używane fonty: http://www.szczakowianka.pl/testowanie/wp-content/themes/musicspace/css/font.css

    Poszukaj fontów z polskimi znakami i je podmień. A jeśli jakiś font nie ma wersji z polskimi znakami, to musisz poszukać czegoś podobnego i tego użyć…

    Chodzi właśnie oto, że nie bardzo chcę zmieniać czcionkę bo ładnie się komponuje z całym wyglądem. Na innej stronie obeszło się bez tego, ale użyty tam sposób nie działa.

    Czy jest ktoś w stanie pomóc? Bo niby zmieniłem czcionkę na jakąś znalezioną w internecie (mogłaby ona zostać), ale nadal polskie litery są jakieś „inne” od pozostałych i brakuje „ó”. Jak sobie z tym poradzić?

    Najprościej użyj fontów googla http://www.google.com/webfonts
    -zaznacz Latin Extended i szukaj fontów poprawnie obsługujących PL znaki
    Oswald akurat z pl sobie radzi.

    No tak, tyle że zmieniłem na Oswald i nadal wyświetla to w jakiś dziwny sposób. Jeśli możesz zerknij na stronę (pierwszy post od góry tutaj jest link) i podpowiedz co robię źle lub co jeszcze zmienić.

    @rafcio94:

    No przecież jeśli font w zestawie znaków nie ma polskich znaków, to nic na to nie poradzisz (no chyba, że chcesz je sobie sam dorobić i pozawala na to licencja fonta).

    Nie kombinuj, tylko znajdź font, który polskie znaki w swoim zestawie znaków posiada…

    A tego Oswalda na pewno pobrałeś z zaznaczonym Latin-ext?

    Może coś źle wgrywam. Czy jest gdzieś dostępny tutorialek jak to wgrać poprawnie, by zadziałało?

    Jak masz kłopot z eksportem, to po prostu wrzuć w head.php (czy tam innym pliku odpowiedzialnym u siebie za nagłówek strony) w sekcję head taką linijkę
    <link href='http://fonts.googleapis.com/css?family=Oswald&subset=latin,latin-ext' rel='stylesheet' type='text/css' />
    potem usuń wszystko co masz w pliku font.css

    ps. tutaj masz wszystko ładnie opisane jak używać fontów googla i co i jak można sobie tam poustawiać.

    Hmm, niestety to w tym stylu nie jest takie łatwe jak się może wydawać. Jest bardzo dziwnie zbudowany … Sam mam problem go ogarnąć.

    Byłbyś w stanie pomóc poza forum? Bo niestety sam chyba tego nie zrobię. Jeśli tak to podaj jakiś kontakt do siebie lub coś podobnego.

    Ok, tutaj jest paczka z podmienionymi na szybko fontami oswald + oxygen
    http://speedy.sh/u8RkZ/musicspace.zip

    Dzięki wielkie, działa wszystko ładnie.

    Żeby nie zakładać nowego tematu, podepnę się jeszcze pod to. Czy wiesz jak dostać się do pliku, gdzie będę mógł zedytować „In category Bez kategorii on 14 lutego 2013” bo nie mogę znaleźć.

    plik theloop.php ok. 47-49 linijki

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Problem z czcionką’ is closed to new replies.