Wsparcie » Używanie i konfiguracja WordPressa » problem z biblioteką mediów

  • Rozwiązany alek99

    (@alek99)


    mam problem z dodawaniem plików do biblioteki mediów (nie jestem programistą więc jeżeli zechcecie pomóc to proszę łopatologicznie:-))

    dokopałam się, że może pomóc modyfikacja pliku wp-config.php przez dodanie linii define( ‚WP_MEMORY_LIMIT’, ’64M’ ); niestety nie pomogło

    problem jest taki:
    – zdjęcia przez ftp dodają się do katalogu uploads ale nie pojawiają w bibliotece mediów
    – zdjęcia dodawane przez wordpressa – nie pojawiają się na serwerze w katalogu uploads, ikony nie wyswietlają zdjecia, po wejsciu w szczegoly tez nic nie widac
    – po dodaniu zdjecia do wpisu pokazuje sie sciezka ale zdjecie nie wyswuetla sie ani z poziomu wordpressa ani z poziomu strony

    z góry dziękuję

Viewing 15 replies - 1 through 15 (of 17 total)
  • A gdy wejdziesz pod adres, właśnie pod tą ścieżkę to jest tam fotografia?
    Podczas uploadu nie ma żadnego błędu?

    nie nie pojawia żaden błąd, ale jak napisałeś o ścieżkach, jeszcze raz sprawdziłam ścieżki…i najprostsze co mogło być…niezupdate’ował się link w ustawieniach/media – podczas migracji musialo gdzies jeszcze zostać
    problem rozwiązany
    dzięki

    Mam taki sam problem jak alek99.

    – zdjęcia przez ftp dodają się do katalogu uploads ale nie pojawiają w bibliotece mediów
    – zdjęcia dodawane przez wordpressa – nie pojawiają się na serwerze w katalogu uploads, ikony nie wyswietlają zdjecia, po wejsciu w szczegoly tez nic nie widac
    – po dodaniu zdjecia do wpisu pokazuje sie sciezka ale zdjecie nie wyswuetla sie ani z poziomu wordpressa ani z poziomu strony
    obrazek wyrozniajacy

    Kiedy wchodzę na adres pod którym powinno być zdjęcie, nie ma go tam a podana strona nie istnieje
    Brak strony

    • Ta odpowiedź została zmodyfikowana 3 years, 3 months temu przez nivenl.
    Moderator amistad18

    (@amistad18)

    A co w konsoli widać podczas uploadu zdjęć?
    Jaki hosting?

    btw. samo wysłanie zdjęcia przez FTP do katalogu uploads nie powoduje jego automatycznego załadowania do biblioteki mediów.

    wgrywanie zdjęć do biblioteki mediów z poziomu WP nic nie daje. Pokazują się tylko ikonki uszkodzonego zdjęcia.
    Hosting jest na fasthosts.co.uk
    Mogę dodać zdjęcia za pomocą galerii NextGEN i wtedy w poście się wyświetlają, ale dalej nie mogę ustawić obrazka wyróżniającego, bo pokazuje tylko ikonkę uszkodzonego zdjęcia.

    Wydaje mi się, że błąd może jest gdzieś po stronie skryptu, który tworzy miniaturę? Jak wchodzę do edycji zdjęcia w bibliotece, to pokazują się szczegóły załączonego pliku – zdjęcie jest widoczne ale nie pokazuje się miniaturka tylko ikonka uszkodzonego obrazka.
    zrzut ekranu

    Moderator amistad18

    (@amistad18)

    Ponawiam pytanie:

    A co w konsoli widać podczas uploadu zdjęć?

    W konsoli wszystko wygląda na początku ok. Zdjecie sie przegrywa.
    konsola1
    Jak się kończy przegrywać pokazuje się ikonka uszkodzonego pliku zamiast miniatury

    konsola2

    Moderator amistad18

    (@amistad18)

    Pokaż wszystko co jest zwracane w konsoli w trakcie i po wgrywaniu pliku.

    W trakcie przegrywania zdjęć do biblioteki jest wskazana kreska postępu:
    wgrywanie

    A po przegraniu. Pokazuje się widok uszkodzonego obrazka.
    po

    Moderator amistad18

    (@amistad18)

    To nie jest konsola a zwykły screen z wp-admina podczas wgrywania pliku.

    Konsola w Firefoxie – crtl + shift + k
    Konsola w Chrome – ctrl + shift + j

    Konsola wygląda tak:
    konsola

    Ktoś z forumowiczów mi doradził, żeby sprawdzić ustawienia dostępu i je zmienić w katalogu uploads na 744. Próbowałam to zrobic przez FileZillę, ale uprawnienia wciąż są takie same czyli 700. Próbowałam to zrobić bezpośrednio przez Website file managera to dostaję taki komunikat: Unable to execute site command chmod 0744 /htdocs/wp-content/uploads. Note that the CHMOD command is only available on Unix FTP servers, not on Windows FTP servers.
    Napisałam do Fasthosts i otrzymałam taką wiadomość:
    „I was now able to changed the file permission for uploads folder into 744.

    bash-4.2$ cd wp-content
    bash-4.2$ ls
    gallery index.php languages ngg ngg_styles plugins themes upgrade uploads
    bash-4.2$ chmod -R 744 uploads
    bash-4.2$ ls -al
    total 1
    drwx—r-x 1 csh980739 linuxgroup500 471537476 Aug 5 14:57 .
    drwx—r-x 1 csh980739 linuxgroup500 492222257 Aug 10 20:27 ..
    drwxr-xr-x 1 csh980739 linuxgroup500 279742284 Aug 4 09:34 gallery
    -rw-r–r– 1 csh980739 linuxgroup500 28 Jan 8 2012 index.php
    drwx—r-x 1 csh980739 linuxgroup500 2157744 Mar 25 12:36 languages
    drwx—r-x 1 csh980739 linuxgroup500 0 Mar 26 16:41 ngg
    drwx—r-x 1 csh980739 linuxgroup500 226 May 5 19:06 ngg_styles
    drwx—r-x 1 csh980739 linuxgroup500 54345154 Aug 10 14:39 plugins
    drwx—r-x 1 csh980739 linuxgroup500 5018978 Jul 22 22:49 themes
    drwx—r-x 1 csh980739 linuxgroup500 0 Aug 10 14:39 upgrade
    drwxr–r– 1 csh980739 linuxgroup500 130273062 Aug 10 14:49 uploads”

    Niby uprawnienia mi zmienili, ale jak otwieram klienta ftp to dalej wszystko jest na 700
    ftp_widok

    Już nie wiem w ogóle co z tym wszystkim zrobić. 🙁

    Moderator amistad18

    (@amistad18)

    Nie interesują mnie błędy związane z problemem z dostępem do już wysłanych ale nie istniejący plików, interesuje mnie co się dzieje podczas wysyłania nowego pliku.

    Więc otwórz konsolę, zjedź na sam dół, rozpocznij wysyłanie nowego pliku, a na koniec wklej mi screena z zakładki response i headers. Jak w konsoli Ci tego nie złapie to przełącz się na zakładkę Newtork.

    wgrywanie

    Niestety nie mam zielonego pojęcia gdzie znaleźć te zakładki 🙁

    Moderator amistad18

    (@amistad18)

    W moim profilu masz podany mój adres email, utwórz mi konto w wp-adminie z uprawnieniami abym mógł wgrywać zdjęcia i podeślij mi dostępy, sam sobie sprawdzę błędy w konsoli 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘problem z biblioteką mediów’ is closed to new replies.