Wsparcie » Używanie i konfiguracja WordPressa » Problem z adresem (tyko) strony głównej po zmianie URL

  • Witam mam zainstalowanego wordpressa na swoim prywatnym serwerze na laptopie. nie posiadam domeny więc do załadowania strony używam adresu serwera np: 192.168.0.12/wordpress. Problem tkwi w tym że czasem mój adres ip się zmienia więc w bazie danych tez muszę go zmienić. Tylko że nie zawsze to działa. Czasem gdy w wp-options zmienię siteurl i home to wszystko działa normalnie a czasem nie. np ostatnio miałem adres 192.168.0.12 musiałem go zmienić w bazie danych na 192.168.0.11 to po wpisaniu w wyszukiwarkę adresu 192.168.0.11/wordpress pisze nie znaleziono adresu 192.168.0.12. żeby się dostać do kokpitu muszę podać adres 192.168.0.11/wordpress/wp-admin i tam działa wszystko poza przejściem do strony. ktoś wie jak to naprawić?? z góry dziękuje za odpowiedź.

Viewing 4 replies - 1 through 4 (of 4 total)
  • A na localhost albo 127.0.0.1 nie dasz rady używać?
    Możesz też np. w wp-config.php wrzucić

    define('WP_HOME', 'http://' . $_SERVER['HTTP_HOST'] . '/wordpress');
    define('WP_SITEURL', 'http://' . $_SERVER['HTTP_HOST'] . '/wordpress');
    Thread Starter kacper1263

    (@kacper1263)

    nie bo serwer mam postawiony na debianie a strone odpalam z innego kompa
    EDIT dodałem to co napisałeś. nadal nie działa

    • Ta odpowiedź została zmodyfikowana 5 years, 3 months temu przez kacper1263.

    A gdzie konkretnie dodałeś? – mam nadzieję, że nie na samym końcu? ….musi być przed require_once.

    Thread Starter kacper1263

    (@kacper1263)

    dodałem po informacjach potrzebnych do logowania do bazy danych. na pewno nie na samym końcu. tam gdzie było pełno define(’wp-… .

Viewing 4 replies - 1 through 4 (of 4 total)
  • Temat ‘Problem z adresem (tyko) strony głównej po zmianie URL’ jest zamknięty na nowe odpowiedzi.