Wsparcie » Używanie i konfiguracja WordPressa » polskie znaki nie działają

  • tynix

    (@tynix)


    Witam.

    Szukałam po różnych forach rozwiązania mojego problemu. Mam stronę w wordpress’ie ( http://www.unlimitedempire.com ) , theme: Ronneby, który używa Google Fonts. Na przeglądarce Chrome wszystkie czcionki działają poprawnie, na FireFox’ie polskie znaki wyświetlają się nieprawidłowo, jedynie Open Sans działa jak należy. Natomiast w przeglądarkach na MAC’ach czy iPhone’ach polskie znaki w ogóle nie działają poprawnie.

    Znalazłam wiele wypowiedzi o tym, aby pogrzebać w plikach header.php i style.css i żeby do linku skąd pobierane są czcionki dodać „latin-ext” itp itd. Zajrzałam gdzie trzeba i moje pliki wyglądają zupełnie inaczej niż innych użytkowników, którzy rozwiązywali podobny problem. Mianowicie:
    Mój header.php:
    <!DOCTYPE html>
    <!–[if lt IE 7]> <html class=”no-js ie lt-ie9 lt-ie8 lt-ie7″ <?php language_attributes(); ?>> <![endif]–>
    <!–[if IE 7]> <html class=”no-js ie lt-ie9 lt-ie8″ <?php language_attributes(); ?>> <![endif]–>
    <!–[if IE 8]> <html class=”no-js ie lt-ie9″ <?php language_attributes(); ?>> <![endif]–>
    <!–[if gt IE 8]> <html class=”no-js ie lt-ie10″ <?php language_attributes(); ?>> <![endif]–>
    <!–[if gt IE 9]><!–> <html class=”no-ie” <?php language_attributes(); ?>> <!–<![endif]–>

    <head>

    <meta charset=”utf-8″>

    <title><?php wp_title(’|’); ?></title>

    <?php
    global $dfd_ronneby;
    if(isset($dfd_ronneby[’custom_favicon’][’url’]) && $dfd_ronneby[’custom_favicon’][’url’]) : ?>
    <link rel=”icon” type=”image/png” href=”<?php echo esc_url($dfd_ronneby[’custom_favicon’][’url’]) ?>” />
    <?php endif; ?>

    <meta name=”viewport” content=”width=device-width, initial-scale=1.0″ />

    <!–[if lte IE 9]>
    <script src=”<?php echo get_template_directory_uri(); ?>/assets/js/html5shiv.js”></script>
    <![endif]–>
    <!–[if lte IE 8]>
    <script src=”<?php echo get_template_directory_uri(); ?>/assets/js/excanvas.compiled.js”></script>
    <![endif]–>

    <?php dfd_custom_page_style(); ?>

    <?php wp_head(); ?>

    </head>

    Mój style.css:
    /*
    Theme Name: Ronneby
    Theme URI: http://themes.dfd.name/ronneby/
    Description: Ronneby – Highly Functional Multifaceted WP Theme
    Version: 1.1.0
    Author: DFD
    Author URI: http://dfd.name/
    Tags: light, white, one-column, two-columns, three-columns, right-sidebar, flexible-width, custom-background, custom-header, custom-menu, featured-images, microformats, post-formats, rtl-language-support, sticky-post, theme-options, translation-ready

    License: xxx
    License URI: xxx
    */

    Nie widzę tu żadnych informacji o czcionkach. Dodam, że pozmieniałam już wszystkie możliwe opcje dotyczące czcionek w samym panelu wordpress’a – w ustawieniach theme’u, ustawieniach wordpressa, ustawieniach Google Fonts… i nie mam pojęcia co i jak jeszcze mogę zrobić.

    Bardzo proszę o pomoc.

Viewing 3 replies - 1 through 3 (of 3 total)
  • jaworowicz

    (@jaworowicz)

    Musisz znależć (pewnie w functions.php) funkcji pobierającej style i skrypty

    Będzie to coś w stylu

    function jakasfunkcja() {
    
    wp_enqueue_style( 'nazwamotywu-google-fonts', 'http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,700italic,400,700,300', false );
    }
    
    add_action( 'wp_enqueue_scripts', 'jakasfunkcja' );

    w powyższym przykładzie powinno wyglądać to tak:

    function jakasfunkcja() {
    
    wp_enqueue_style( 'nazwamotywu-google-fonts', 'http://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,700italic,400,700,300&subset=latin,latin-ext', false );
    }
    
    add_action( 'wp_enqueue_scripts', 'jakasfunkcja' );

    Z tego co widzę czcionki się (przynajmniej u mnie) ładują poprawnie.

    Thread Starter tynix

    (@tynix)

    Dzięki za odpowiedź. W functions.php mam tak:

    # Including theme components
    require_once locate_template('/inc/includes.php');
    
    add_action('after_setup_theme', 'dfd_eight_setup_theme');
    
    if (!function_exists('dfd_eight_setup_theme')) {
    	function dfd_eight_setup_theme() {
    
    		// Enqueue theme scripts and styles
    		add_action('wp_enqueue_scripts', 'dfd_kadabra_enq_fonts');
    		add_action('wp_enqueue_scripts', 'dfd_kadabra_scripts', 100);
    
    		// Enqueue admin scripts and styles
    		add_action('admin_enqueue_scripts', 'dfd_kadabra_admin_css');

    Więc… po pierwsze: pokazuje mi theme Kadabra, a nie Ronneby, po drugie: nie ma tu żadnych informacji o Google Fonts.

    Nadal nie wiem gdzie szukać błędu :/ a chciałabym to jakoś sama (i za pomocą forumowiczów) naprawić i zrozumieć

    Przypomnę, że obecnie mam wybraną czcionkę Open Sans, która nie wyświetla się na komputerach typu MAC oraz przeglądarce Safari na iPhone’ach. Gdybym zmieniła teraz czcionkę na np Doris (która jest jako ta oryginalna w moim theme’ie) to polskie znaki wyświetlałyby się jedynie na przeglądarce Google Chrome.

    jaworowicz

    (@jaworowicz)

    Napisz proszę do mnie na mail mateusz[@malpa@]jaworowi.cz, gdyż muszę zobaczyć dokładnie kod motywu.

    W którymś pliku znajduje się odwołanie do funkcji dfd_kadabra_enq_fonts, zaś same czcionki ładują się przez dziwny javascript.

    Na ile to możliwe naprawię ten problem, a na forum wskażę konkretne rozwiązanie.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Temat ‘polskie znaki nie działają’ jest zamknięty na nowe odpowiedzi.