WordPress.org

Polska

Fora

[Resolved]: polskie znaki na stronie!!!


  • morarz
    Członek

    @morarz

    Witam,

    Nie wiem dlaczego nie mam polskich znaków na stronie www.

    Mam je w panelu admina ale próbowałem wszystko i nie działa.

    Jak ustawić polskie znaki ??

Viewing 15 replies - 1 through 15 (of 16 total)

  • grochu
    Członek

    @grochu

    a jakie masz kodowanie ustawione? UTF-8?


    morarz
    Członek

    @morarz

    Tak UTF-8

    A w pliku header.php na początku mam tak :
    Jakakolwiek zmiana na polskie kodowanie nic nie daje….

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    
    <head>
    	<meta charset="<?php bloginfo('charset'); ?>" />
    	<meta name="distribution" content="global" />
    	<meta name="language" content="en, pl" />


    grochu
    Członek

    @grochu

    tutaj akurat na moje oko wszystko jest ok, a jakim programem edytowałeś pliki wp?


    morarz
    Członek

    @morarz

    Wiesz na początku stronę zrobiłem w photoshopie później przeniosłem ją do HTML i CSS i tam kodowanie jest ok. Problem jest gdy przerzuciłem stronę do WordPressa. Jak skończę edytować stronę to podam do Niej link. Ogólnie to pliki stron edytuje w notepad C++ 🙂


    amistad18
    Moderator

    @amistad18

    notepad C++

    Jesteś tego pewien?

    Podaj adres strony.


    morarz
    Członek

    @morarz

    pliki wp (.php) edytuje notatnikiem a jak inaczej 🙂 ?

    O jakie edytowanie Wam chodzi ??

    Jeszcze nie skończyłem zmieniać strony. Zaraz ją podam bo narazie na niej nic nie ma.


    morarz
    Członek

    @morarz

    http://garwolinskie.info/test/ adres strony. A i jeszcze jedno pytanie dlaczego nie wyświetla mi się w prawej kolumnie flash ?

    Kod do flasha :

    <div id ="right_side">
    	<ul>
    		<li>
    <object data="swf/banner1.swf" type="application/x-shockwave-flash" align="center" height="90" width="200"> Reklamy i bannery dla firm
    <param name="pluginurl" value="http://www.macromedia.com/go/getflashplayer">
    </object>
    		</li>
    	</ul>
    </div>

    W htmlu wszystko działa po wrzuceniu do wordpress dupa.


    amistad18
    Moderator

    @amistad18

    Nie ma najmniejszego problemu z kodowaniem strony, zapewne wina jest w kodowaniu plików. Musisz teraz wszystkie pliki szablonów edytować, i zmienić im kodowanie na UTF-8 – i przy okazji poprawić krzaki które się pojawią w kodzie przy polskich znakach.

    Odnośnie flash’a – podaj ścieżkę do pliku wraz z http itd, a nie samo swf/banner1.swf


    morarz
    Członek

    @morarz

    O shit to nie dobrze. Myślałem że WordPress zrobi to za mnie…
    Powiedz mi dlaczego jak zadeklaruje w home.php tam gdzie nie ma polskich znaków :

    <html <?php language_attributes(); ?>>
    
    <meta charset="<?php bloginfo('charset'); ?>" />

    To i tak nie zmieniają się polskie znaki przecież bloginfo(‚charset’) znaczy tyle co żeby wrzucić ustawione kodowanie z WordPress ?


    amistad18
    Moderator

    @amistad18

    Jak WordPress zrobi to za Ciebie? Przeglądarka chce czytać treść strony z kodowaniem UTF-8, bo tak ma wskazane – natomiast jak TY zapisujesz pliki z jakimś ISO czy innym, no to efekty masz takie jak widzisz.


    morarz
    Członek

    @morarz

    To jak Ty masz wpisane kodowanie ?

    Zadnych ISO nie ustawiałem mam wszędzie UTF-8 które powinno być pobierane z ustawien wp.

    Przy podglądzie strony nawet jest napisane UTF-8 i za cholere nie działa…


    amistad18
    Moderator

    @amistad18

    Też korzystam z kodowania UTF-8 na stronie, oraz pliki edytuję programem Notepad++ i zapisuję z kodowaniem UTF-8 bez BOM … zaznaczę – WSZYSTKIE PLIKI. Więc przestań marudzić – tylko zacznij wszystkie pliki szablonu przerabiać na kodowanie UTF-8 bez BOM, o czym już wcześniej mówiłem, cała ta rozmowa jest bezcelowa.


    morarz
    Członek

    @morarz

    amistad18 OK tak zrobię ale dopiero zaczynam z wordpress 😉

    Co to jest BOM ?


    amistad18
    Moderator

    @amistad18

    http://pl.wikipedia.org/wiki/BOM

    Nie mówię o WordPressie, a o kodowaniu plików szablonu – o ich edycji np. Notepadem++ i zmianie kodowania w nich – z WP to ma tyle wspólnego, że to jest szablon do WP, ale sam WP tutaj nie ma nic do gadania. Trzeci raz to piszę, nie wiem jak inaczej Ci to wyjaśnić. W razie wątpliwości przeczytaj moje posty jeszcze raz, i kolejny, i kolejny – aż się uda.


    morarz
    Członek

    @morarz

    Ale jaja masz całkowitą rację zmieniłem kodowanie na UTF-8 w notepad ++ z ANSI i działa 🙂 Dzięki powinno się ten temat przykleić żeby inni wiedzieli ocb ;P

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved]: polskie znaki na stronie!!!’ is closed to new replies.