Wsparcie » Instalacja » Polska Wersja

  • Tak jak w tytule nie działa mi Polska wersja WP 3.3.1.Robiłem wszystko tak jak na instrukcji i nawet czytałem pomoce ale nie działa.

Viewing 10 replies - 1 through 10 (of 10 total)
  • przecież masz pliki Polskiej wersji, jak może nie działać

    Nowe tematy na tym forum to jakiś żart?

    Nie bardzo rozumiem. Pobrałeś Polską wersję wordpress, zainstalowałeś i masz angielską? Czy też całkiem Ci nie działa?

    wildchild84

    (@wildchild84)

    No ja mam właśnie taki problem… Instaluję polską wersję WP 3.1.3 (pobraną z różnych źródeł, z tej strony też), odpalam instalator i na początku jest ok. Wypełniam dane wymagane do utworzenia pliku konfiguracyjnego… I od tej pory mam już wersję angielską, dokładnie od momentu gdzie zakłada się konto administratora, ustawia nazwę strony itd (czyli po kliknięciu na „uruchom instalację”). W pliku konfiguracyjnym ustawiony jest język polski, a pomimo tego strona jest w całości po angielsku. Co więcej, w językach nawet nie ma wrzuconego innego niż polski…

    Moderator Paweł Knapek

    (@adpawl)

    Dla pewności, polska wersja 3.3.2. Jeszcze mi sie nie zdarzyło by instalując pl nie mieć pl …ale nawet gdyby faktycznie taki przypadek miał miejsce, to dodaj do pliku konfiguracyjnego linijkę:
    define ('WPLANG', 'pl_PL');

    wildchild84

    (@wildchild84)

    No właśnie, w tym rzecz, że wcześniej też mi się to nigdy nie zdarzyło, a instalowałem już WP wiele razy. I uwierz mi, że ta linijka absolutnie nic nie zmienia, próbowałem tego na samym początku. Potem podmieniałem pliki, konfigi, robiłem je ręcznie wg. podanego „sampla” itd. itp. I to wszystko nic nie dawało. Dopiero jak zrobiłem aktualizację (z 3.1.3 o którym pisałem do 3.3.2) to pojawił się język polski. Więc generalnie problem się rozwiązał, może nie do końca jak chciałem, ale jednak…

    qdlatek

    (@qdlatek)

    Witam,
    Miałem podobny problem, ale go rozwiązałem:
    przy kopiowaniu WordPress na serwer można zaznaczyć kopiowanie z zamienianiem dużych znaków na małe (różnie może to być opisane dla różnych programów) co jest skutkiem błędnego interpretowania przez serwer nazw poszczególnych plików.
    W katalogu: wp-content/languages znajdował się plik pl_pl.mo ,a niepl_PL.mo

    To jest przyczyną nierozpoznania pliku i wyświetlanie angielskiej wersji językowej.

    Pozdrawiam

    rwtryb

    (@rwtryb)

    qdlatek super sprawa 🙂 przyznam się szczerze, nawet nie przyszło mi to przez myśl.

    Moderator Paweł Knapek

    (@adpawl)

    Może tak być, przy czym jest to efekt po prostu nieprawidłowo przeprowadzonego uploadu ….i objawia się na serwerach linuxowych, które w odróżnieniu od windowsowych są case-sensitive.

    wildchild84

    (@wildchild84)

    @qdlatek – no fakt, tego nie sprawdziłem, tak mogło być.

    @adpawl – upload NIE MÓGŁ być przeprowadzony „nieprawidłowo” bo była to identyczna wersja (dosłownie z tej samej paczki .zip), którą wcześniej instalowałem na innym koncie www na tym samym serwerze. I w pierwszym przypadku działało, a w drugim nie. Co ciekawe, nawet jak skopiowałem wszystkie pliki z działającej normalnie instalacji na to drugie konto to język i tak był angielski.

    Moderator Paweł Knapek

    (@adpawl)

    @wildchild84, jesteś w błędzie. Jeżeli zaszedł przypadek opisany przez kolegę @qdlatek, to jest to jak najbardziej nieprawidłowo przeprowadzony upload – bo nie wgrywasz jak jest a ingerując w nazewnictwo plików …i nie ma tutaj znaczenia czy wgrywasz WP czy cokolwiek innego.
    W 3.3.1 są również pliki pl_PL, więc nie ma bata żeby nie działało – jeżeli masz inaczej to niestety z własnej winy lub niewiedzy.
    Inny jeszcze przypadek braku tłumaczenia, to mogą być nieprawidłowe chmody.

    Ważne, że problem jest rozwiązany.
    Taka mała uwaga na przyszłość, nie instaluj wp z różnych źródeł a tylko aktualną wersję z oficjalnej strony.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Polska Wersja’ is closed to new replies.