Wsparcie » Używanie i konfiguracja WordPressa » Niepowodzenie w zmianie maksymalnego rozmiaru przesyłanych plików

  • Witam

    Jak w temacie, mam problem ze zwiększeniem limitu wielkości przesyłanych plików.
    W WordPressie wyświetla mi się Maksymalna wielkość dodawanych plików: 8 MB.
    Żeby to zmienić zwiększyłem upload_max_filesize w php.ini do 200M. Dodatkowo zrobiłem także dla starszych wersji php. Tak na wszelki wypadek. Dodałem wpisy:
    define(’WP_MEMORY_LIMIT’, '128M’);
    define(’WP_UPLOAD_MAX_SIZE’, '128M’);
    define(’WP_POST_MAX_SIZE’, '164M’);

    oraz
    @ini_set( 'upload_max_size’ , '128M’ );
    @ini_set( 'post_max_size’, ’64M’);
    @ini_set( 'memory_limit’, '128M’ );

    w wp-config.php, bo takie dwie opcje wyczytałem.
    Przy wrzucaniu tego do function.php motywu strona wyleciała w powietrze.
    Próbowałem załatwić sprawę zwiększenia wtyczką, ale mimo teoretycznego zwiększenia się limitu w WordPressie, program wywala błąd:
    Nieoczekiwana odpowiedź z serwera. Plik mógł zostać pomyślnie przesłany. Proszę sprawdzić w bibliotece mediów lub ponownie załadować stronę.
    Oczywiście plik (pdf) się nie dodaje.

    Php.info pokazuje:
    upload_max_filesize 200M 200M
    max_file_uploads 20 20
    memory_limit 128M 128M

    Czyli tak jakby było dobrze.

    Przyznam się, że nie mam pliku .htacces i w sumie nie za bardzo chciałbym go mieć, bo serwer nie jest sprinterem. Poza tym nie mam doświadczenia w jego tworzeniu

    Wie ktoś jak rozwiązać taki problem? każda rada będzie cenna. Czy to coś z WP, czy może z dodatkami?
    WordPress: 5.4
    PHP: 7
    motyw: Vantage
    system: Ubuntu 16.04

Viewing 13 replies - 1 through 13 (of 13 total)
  • Nie wrzuca się w functions.php, tylko jeżeli już, to w wp-config.php jeszcze przez końcowym require_once…

    Z .php usuń te deklaracje, zostaw tylko w php.ini i sprawdź co pokaże php_info()

    Sprawdź jaki konkretnie błąd wywala w error logu.

    Thread Starter bollim

    (@bollim)

    Przy samym limicie w php.ini jest to samo. Od tego zacząłem. Dopiero później kombinowałem.

    Thread Starter bollim

    (@bollim)

    Co do błędów to debug.log WordPressa nie widzie tego jako błąd.

    Nie debug, tylko Error Log serwera.
    Debug nie łapie wszystkiego i zwykle mniej szczegółowy.

    Thread Starter bollim

    (@bollim)

    Czy chodzi o error.log Apacha? Ten nie pokazuje nic związanego z tym problemem. Jedynie trzy linijki z sierpnia kiedy mieliśmy awarię zasilania.

    Dla pewności spróbował bym jeszcze łapać błędy przez .htaccess https://perishablepress.com/how-to-enable-php-error-logging-via-htaccess/

    Natomiast wracając jeszcze do samego limitu, to jeżeli wrzucisz w lokalizację WordPressa pliczek php z

    <?php
    phpinfo();

    i wołając go w przeglądarce dostaniesz właściwe (nowe) limity ….a w samym WP pokazuje inną wartość, to by wskazywało, że gdzieś na stronie są one znowu zamieniane.
    ( oczywiście musisz wcześniej pozbyć się swoich define i ini_set, które nawrzucałeś w wp-config.php, functions.php albo jeszcze gdzie indziej).

    No więc jeżeli po tych zmianach phpinfo() będzie ok, a w samym WP dalej będzie źle, to znaczy że coś poza tobą jeszcze próbuje zmieniać limity i musisz pod tym kątem przetrzepać motyw i używane wtyczki.

    Thread Starter bollim

    (@bollim)

    dokładnie. Prawdopodobnie gdzieś w WordPressie to siedzi, ale nie wiem gdzie to może być. Po to próbowałem zmieniać function dla motywu. Wyłączałem go jednak i problem dalej był. Mam na serwerze trzy strony, na każdej są inne wtyczki, ale być może któreś się pokrywają. Sprawdzę to.
    Dzięki.

    Jeżeli grep jest za trudny, to możesz sobie pobrać motyw i wtyczki i przeszukać je na frazy WP_UPLOAD_MAX_SIZE / upload_max_size ….albo szerzej na ini_set(.
    Pod Windowsa fajny jest do tego SearchMyFiles pakietu NirSoft

    Thread Starter bollim

    (@bollim)

    Niestety nic nie znalazłem.
    Za to zainstalowałem nowego w WordPressa i, jak się okazuje, w czystym WP jest ten sam problem.

    Thread Starter bollim

    (@bollim)

    Może ktoś ma jeszcze inne pomysły?

    A jak usuniesz wszystko i wgrasz wtyczkę od zmieniania tej wartości to dalej masz to samo? Nie polecam tej metody, ale do weryfikacji powinno wystarczyć.

    Thread Starter bollim

    (@bollim)

    Niestety tak 🙁 próbowałem

    Jeżeli nie masz tam produkcyjnych danych osobowych podeślij mi namiar na FTP – konsultacje@jaworowi.cz . W ramach forum wyczerpaliśmy już wszystkie opcje nie wymagające zajrzenia do środka. Oczywiście bezplatnie bo, aż mnie ten przypadek zaintrygował.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Temat ‘Niepowodzenie w zmianie maksymalnego rozmiaru przesyłanych plików’ jest zamknięty na nowe odpowiedzi.