Wsparcie » Motywy » Nie widać dodanego wpisu, szablon DIVI

  • Prowadzę stronę http://www.lekomaniablog.pl/ na szablonie DIVI i mam problem taki, że ostatni dodany wpis nie wyświetla mi się na stronie głównej, choć fizycznie istnieje. W kategoriach, po prawej stronie w sidebarze normalnie się wyświetla i można w niego wejść, na dole w stopce też jest informacja o dodaniu wpisu, jego tytuł, w panelu administracyjnym też wyświetla się jako dodany oraz jego tytuł, a na stronie głównej nic..

    Poprzedni wpis jakiś czas temu dodał mi się bez problemu..
    Jedyną rzecz jaką w tym czasie zrobiłem, to aktualizacja szablonu do nowszej wersji, ponieważ pojawiła się wersja DIVI 2.7, a praktycznie dzień później druga aktualizacji DIVI 2.7.1..

    Jakiś czas temu miałem podobny problem z kolei po aktualizacji WordPressa, wprawdzie na stronie głównej wyświetlała się grafika i zajawka wpisu, ale po kliknięciu wyświetlał się komunikat nie znaleziono strony, teraz nie wyświetla się nic

    Proszę o pomoc, kompletnie nie wiem jak sobie z tym poradzić, jestem laikiem w tych sprawach

Viewing 14 replies - 16 through 29 (of 29 total)
  • OK, zainstaluje..

    Czy na tym forum można dodawać Print Screeny? Jeśli tak, to jak?

    zrób zrzut, dodaj np. na postimage.org i wrzuć link

    Opcję na samej górze zmień na „najnowsze wpisy”.

    No właśnie, tu jest problem, że nie mogę tego zrobić, bo jak mam ustawione „najnowsze wpisy” znika w szablonie DIVI cały Slider i nie ma go w ogóle, dlatego musiałem za radą kogoś, bodajże Dominika Jędrzejczaka, który na YouTube w jednym z filmików omawia funkcje tego szablonu zmienić na statyczną stronę.. i tak od początku mam.

    ..ale do tej pory wpisy i kategorie wyświetlały się bez problemu..

    Zapewne dałoby się włączyć to w inny sposób ale ok.

    1. Zaloguj się do panelu admina.
    2. Przejdź na stronę główną.
    3. Kliknij „edytuj stronę”(mowa o statycznej stronie, która działa jako strona główna).
    4. Przełącz na tryb tekstowy i przekopiuj zawartość tutaj(całość zaznacz i kliknij tutaj w edytorze na „code”).

    Jak rozumiem masz stronę statyczną, na której jest slider, 3 boksy i jakiś kod wywołujący wpisy. Prawdopodobnie z tym ostatnim jest problem.

    Po wejściu w panel admina, po lewej stronie w kokpicie jak w każdym wordpressie wyświetlają się zakładki : strony (lista, dodaj nową itd.) wpisy (lista, dodaj nowy..), media itd., to jak wejdę w listę stron, a następnie stronę główną ustawioną jako statyczną wyświetla mi się coś takiego:

    https://postimg.org/image/7g9pols79/

    ponieważ tą stronę mam zrobioną w tzw body buliderze, który pozwala na budowanie strony z różnych modułów jak klocki lego, więc jest to „konstrukcja” zbudowana z tych, z tym że w środku jest moduł blog, w którym nie ma wpisu, który można by przełączyć w tryb tekstowy, tylko różne ustawienia dla trybu blogowego..

    Owszem, jest możliwość przełączenia w zwykły edytor wordpressa, ale wtedy boję się trochę stracić slidera i tej konstrukcji..

    Jeśli chodzi o sam wpis, to można go edytować w trybie tekstowym, bo nie mam go zbudowanego w body buliderze, tylko w zwykłym edytorze, ale to normalnie trzeba wejść przez zakładkę wpisy, lista wpisów i w wpis..Wtedy ten wpis w trybie tekstowym wygląda tak (razem ze zdjęciem)..

    Jest jeszcze w panelu admina po lewej stronie coś takiego jak edytor, gdzie można edytować różne elementy bloga

    https://postimg.org/image/4ngi4krut/

    https://postimg.org/image/7itlbfvut/

    w zależności, co się ustawi, ale to chyba w kodzie informatycznym i dla strony głównej kod wygląda tak:

    <?php get_header(); ?>

    <div id=”main-content”>
    <div class=”container”>
    <div id=”content-area” class=”clearfix”>
    <div id=”left-area”>
    <?php
    if ( have_posts() ) :
    while ( have_posts() ) : the_post();
    $post_format = et_pb_post_format(); ?>

    <article id=”post-<?php the_ID(); ?>” <?php post_class( ‚et_pb_post’ ); ?>>

    <?php
    $thumb = ”;

    $width = (int) apply_filters( ‚et_pb_index_blog_image_width’, 1080 );

    $height = (int) apply_filters( ‚et_pb_index_blog_image_height’, 675 );
    $classtext = ‚et_pb_post_main_image’;
    $titletext = get_the_title();
    $thumbnail = get_thumbnail( $width, $height, $classtext, $titletext, $titletext, false, ‚Blogimage’ );
    $thumb = $thumbnail[„thumb”];

    et_divi_post_format_content();

    if ( ! in_array( $post_format, array( ‚link’, ‚audio’, ‚quote’ ) ) ) {
    if ( ‚video’ === $post_format && false !== ( $first_video = et_get_first_video() ) ) :
    printf(
    ‚<div class=”et_main_video_container”>
    %1$s
    </div>’,
    $first_video
    );
    elseif ( ! in_array( $post_format, array( ‚gallery’ ) ) && ‚on’ === et_get_option( ‚divi_thumbnails_index’, ‚on’ ) && ” !== $thumb ) : ?>
    „>
    <?php print_thumbnail( $thumb, $thumbnail[„use_timthumb”], $titletext, $width, $height ); ?>

    <?php
    elseif ( ‚gallery’ === $post_format ) :
    et_pb_gallery_images();
    endif;
    } ?>

    <?php if ( ! in_array( $post_format, array( ‚link’, ‚audio’, ‚quote’ ) ) ) : ?>
    <?php if ( ! in_array( $post_format, array( ‚link’, ‚audio’ ) ) ) : ?>
    <h2 class=”entry-title”>„><?php the_title(); ?></h2>
    <?php endif; ?>

    <?php
    et_divi_post_meta();

    if ( ‚on’ !== et_get_option( ‚divi_blog_style’, ‚false’ ) || ( is_search() && ( ‚on’ === get_post_meta( get_the_ID(), ‚_et_pb_use_builder’, true ) ) ) ) {
    truncate_post( 270 );
    } else {
    the_content();
    }
    ?>
    <?php endif; ?>

    </article> <!– .et_pb_post –>
    <?php
    endwhile;

    if ( function_exists( ‚wp_pagenavi’ ) )
    wp_pagenavi();
    else
    get_template_part( ‚includes/navigation’, ‚index’ );
    else :
    get_template_part( ‚includes/no-results’, ‚index’ );
    endif;
    ?>
    </div> <!– #left-area –>

    <?php get_sidebar(); ?>
    </div> <!– #content-area –>
    </div> <!– .container –>
    </div> <!– #main-content –>

    <?php get_footer(); ?>

    Page builder działa na zasadzie dodawania kodu poprzez rozbudowany edytor wizualny, w tym przypadku na zasadzie dodawania bloków. Przełączać możesz dowolnie pomiędzy edytorami, w tekstowym kod zapewne będzie zminimalizowany bez spacji/przerw.

    Jest jakiś problem z wywołaniem ale nie wiem, czy to wina kodu, czy samego page buildera – aktualizowałeś skórkę/page builder ?

    Rozumiem..Dokładnie tak, jedyną rzeczą jaką zrobiłem przed pojawieniem się tego problemu to aktualizacja szablonu DIVI, która się pojawiła..Później pojawiła się kolejna (myślałem, że coś się naprawi), później bodajże kolejna..Nic więcej nie robiłem na blogu, a przedtem wszystko działało jak trzeba

    ..wciąż niestety jest ten sam problem przy dodawaniu wpisów, może ktoś coś pomóc?..

    http://www.lekomaniablog.pl

    Jak dodam i ustawię, wpiszę jakąś kategorię, która wyświetla się w sidebarze po prawej stronie szablonu, to nie widać na stronie głównej nowo dodanego wpisu 🙁 choć wpis fizycznie istnieje i jak się wchodzi poprzez kategorię to się wyświetla..

    Jak dodam wpis i nie ustawię żadnej kategorii (opcja „uncategorized”) to wpis normalnie jest, no ale nie ma kategorii

    Próbowałeś kontaktować się z autorami skórki? To może być jakiś problem z kodem zaciągającym posty z kategorii.

    Ok, też myślałem o tym, by do nich napisać, tylko trochę „przyrdzewiałem” z językiem angielskim, ale chyba nie ma wyjścia i albo trzeba będzie coś sklecić przy użyciu translatora, albo będę musiał poprosić brata, który jest bardziej biegły w angielskim.. zobaczymy..póki co dzieki za wszelkie porady! pozdr

    A może ktoś mi pomoże tutaj?
    Również motyw Divi.
    Na głównej nie wyświetlają się:
    1. Obrazy.
    2. Obrazy w sliderach.
    3. Slidery w ogóle nie działają.
    4. Number Counters.

    + powstała jakaś niepotrzebna linia kodu na samym dole.

    Pomocy ;_;

    Strona: http://naukaplywaniawalbrzych.pl/

    Powinieneś stworzyć oddzielny temat.

    Nie wiem jak ze sliderem, jednak kod na dole to jakiś niekompletny skrypt do asynchronicznego ładowania js. Może być spowodowany używaniem jakiejś wtyczki, która używa właśnie tego typu funkcji lub nieprawidłowo zagnieżdżonego kodu.

    Możliwe, że po rozwiązaniu problemu z „kodem” reszta również powróci do normy.

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘Nie widać dodanego wpisu, szablon DIVI’ is closed to new replies.