Wsparcie » Motywy » Nie widać dodanego wpisu, szablon DIVI

  • Prowadzę stronę http://www.lekomaniablog.pl/ na szablonie DIVI i mam problem taki, że ostatni dodany wpis nie wyświetla mi się na stronie głównej, choć fizycznie istnieje. W kategoriach, po prawej stronie w sidebarze normalnie się wyświetla i można w niego wejść, na dole w stopce też jest informacja o dodaniu wpisu, jego tytuł, w panelu administracyjnym też wyświetla się jako dodany oraz jego tytuł, a na stronie głównej nic..

    Poprzedni wpis jakiś czas temu dodał mi się bez problemu..
    Jedyną rzecz jaką w tym czasie zrobiłem, to aktualizacja szablonu do nowszej wersji, ponieważ pojawiła się wersja DIVI 2.7, a praktycznie dzień później druga aktualizacji DIVI 2.7.1..

    Jakiś czas temu miałem podobny problem z kolei po aktualizacji WordPressa, wprawdzie na stronie głównej wyświetlała się grafika i zajawka wpisu, ale po kliknięciu wyświetlał się komunikat nie znaleziono strony, teraz nie wyświetla się nic

    Proszę o pomoc, kompletnie nie wiem jak sobie z tym poradzić, jestem laikiem w tych sprawach

Viewing 15 replies - 1 through 15 (of 29 total)
  • Nie używasz przypadkiem jakiejś wtyczki keszującej typu WP Super Cache ?

    Rzeczywiście używam, WP Super Cache, a co (?)

    Wyczyść cache w opcjach wtyczki.

    Dzięki Wielkie!! Wygląda na to, że już wszystko w porządku, wpis się już wyświetla, i w trakcie zalogowania do panelu administracyjnego, i po wylogowaniu Tak jak mówiłem jestem laikiem i nie wiem za bardzo na czym to polega (?), samo wyczyszczenie cache nie pomogło, ani nawet wyłączenie i całkowite usunięcie wtyczki WP Super Cache i ponowne zainstalowanie..

    Dopiero gdy zrobiłem coś takiego (tak przynajmniej mi się wydaje) –> usunięcie wtyczki –> skopiowanie wpisu do schowka, po czym całkowite usunięcie nowego wpisu ze strony –> ponowne dodanie wpisu i od tego momentu wszystko gra, a nawet zamontowałem ponownie wtyczkę i też wpis jest..Zobaczymy jak będzie dalej, jeszcze raz dzięki! 🙂

    Zapewne nie wyczyściłeś ciasteczek w przeglądarce.

    Poszukaj w ustawieniach wtyczki Super Cache, żeby czyścił/aktualizował cache za każdym razem, kiedy jest dodawany lub aktualizowany post. Swoją drogą jeśli masz niewielki ruch na stronie, to zastanowiłbym się, czy jest sens trzymać wtyczkę keszującą – wszędzie pisze się o tym ile to one nie dają ale nie jest to wymóg, jeśli serwer nie ma problemu z ruchem i wielkością strony.

    Jeśli chodzi o ruch na stronie to póki co od 70 – 90 unikalnych użytkowników dziennie, chyba nie dużo, bo jest to blok niszowy, nie jakiś kulinarny, czy o zarabianiu w sieci, ale jeśli chodzi o wielkość strony, to tu sam nie wiem, bo nie ładuje się zbyt szybko i na wykresie Gtmetrix wskazuje, ze jest jakiś problem z cachowaniem,

    https://gtmetrix.com/reports/lekomaniablog.pl/nRLBIR3T

    ktoś mi doradził tą wtyczkę, to zamontowałem

    Usuń cache, następnie usuń WP Super Cache. Przy takim ruchu nie potrzebujesz tego.

    Zainstaluj zamiast tego:
    https://pl.wordpress.org/plugins/wp-fastest-cache/

    Włącz w niej tylko dwie ostatnie opcje, nic innego:
    http://s9.postimg.org/bs26z46jj/1122.png
    – spowoduje to włączenie kompresji gzip i wszystkich zasad keszowania dla przeglądarki(nie dla strony). W ten sposób będziesz miał włączone, to co najważniejsze i nie musisz używać dużych wtyczek dla cache’a.

    Ponadto jeśli masz taką możliwość, to włącz w ustawieniach serwera PHP w wersji 5.6 dla swojej strony – powinna przyspieszyć. Jeśli nie znajdziesz tego w panelu zarządzania lub nie wiesz jak to zrobić, to skontaktuj się z usługodawcą i poproś o przełączenie parsera php na 5.6

    Na koniec użyj wtyczki:
    https://pl.wordpress.org/plugins/rvg-optimize-database/
    – zainstaluj, wejdź w ustawienia i pozaznaczaj opcje następująco:
    http://s21.postimg.org/eby098gmv/image.png
    potem kliknij „Save settings” i wybierz „Go to optimizer” i „Start optimization’. Oczyści to bazę danych z nieużywanych wersji wpisów, pingbacków i innych niepotrzebnych rzeczy, bo tym strona też powinna dostać solidny zastrzyk optymalności.

    PS. Na przyszłość – proponuję publicznie nie dzielić się ruchem na stronie, w Twoim przypadku strona jest dla konkretnej, niewielkiej niszy ale przy większych stronach konkurencja może zebrać dane 🙂

    Wielkie dzięki za wskazówki !! 🙂 Wszystko zastosuje, przetestuje i zdam relację..

    Jednak okazało się, że problem pierwotny istnieje nadal (dodany, nowy wpis nie jest widoczny na stronie głównej) pojawił się znowu i to niezależnie od obecności wtyczki WP Super Cache, którą usunąłem całkiem na jakiś czas, wyczyściłem wcześniej wszystkie ciasteczka zarówno w wtyczce, jak i na stronie przeglądarki..

    Po prostu następnego dnia odpaliłem stronę i znów nie ma wpisu, zacząłem dochodzić krok, o kroku, co robiłem podczas dodawania wpisu (?) a więc dodawanie tagów w wpisie, dodanie seo tittle, stworzenie nowej kategorii, no i okazało się że tu leży „pies pogrzebany”..Po prostu jak dodaje (jak zwykle) nową kategorię, powiedzmy „Uzależnienie od leków nasennych” dodany, nowy wpis znika..jak pozostawiam kategorię „uncategorized” wpis jest i wszystko gra! No i tak na razie mam ustawione

    Jakie masz wtyczki zainstalowane na chwilę obecną?

    przepraszam, nie zawsze mogę odpisać od razu, wtyczki, które na ten moment mam na blogu to:

    a3 Lazy Load
    Acurax On Click PopUnder
    All in One SEO Pack
    Black Studio TinyMCE Widget
    CodeStyling Localization
    Elegant Themes Updater
    Google XML Sitemaps
    Optimize Database after Deleting Revisions (przedwczoraj zamontowałem wg twoich sugestii)
    Post Layout
    Subscribe To Comments
    WP Database Backup
    WP Fastest Cache (przedwczoraj zamontowałem)
    WP Google Analytics
    WP Mobile Edition
    WP-SpamShield

    miałem wtyczki WP Super Cache i wtyczkę
    Better WordPress Minify, ale ta druga gryzła się z WP Fastest Cache, więc musiałem usunąć

    wygląda, że jest lepiej, tzn raz strona ładuje się takim samym czasie jak się ładowała 6.2, a raz krócej, 5.4 – 5.5

    ostatni skan z Gtmetrix
    https://gtmetrix.com/reports/www.lekomaniablog.pl/7jxBwj49

    Zmieniłem też w swoim cpanelu Netmark PHP 5.5 na 5.6

    Strzelam, że wina będzie leżała po stronie jakichś pozostałych wpisów w .htaccess i budowy permalinków ale jak już zacząłem z optymalizacją, to skończę.

    Używasz All in One SEO pack, który ma funkcję map xml – nie potrzebujesz do tego oddzielnego plugina(Google xml sitemaps).

    WP Google Analytics – stary plugin. Podmień na https://pl.wordpress.org/plugins/nk-google-analytics/
    – lub sprawdź, czy przypadkiem Twoja skórka nie ma możliwości bezpośrednio podpięcia tego kodu(np. w personalizacji > footer)

    WP Mobile Edition – Divi przypadkiem nie jest responsywną skórką?

    Już nie potrzebujesz żadnych wtyczek „przyspieszających”. Fastest Cache z tymi dwoma zasadami w zupełności wystarczy.

    Wracając do problemu.
    1. Zrób kopię pliku .htaccess na ftp. Potem usuń go. Otwórz stronę i wejdź do panelu admina.
    2. Wejdź do Ustawienia > Bezpośrednie odnośniki
    3. Zaznacz obojętnie jaką opcję, zapisz, następnie zaznacz poprzednią opcję i ponownie zapisz.

    Sprawdź po tym co się będzie działo.

    Tak, miałeś racje, DIVI jest sam w sobie responsywnym szablonem i nie trzeba już dodatkowej wtyczki WP Mobile Edition (odinstalowałem)

    rzeczywiście również wtyczka Google XML Sitemaps nie jest potrzebna, (odinstalowałem ją) ponieważ mapę strony można rzeczywiście ustawić w All in One SEO Pack

    Dzięki Twoim sugestią moja strona coraz lepiej chodzi – dzięki!

    kolejna rzecz : za twoją radą odinstalowałem starą wtyczkę Google Analictics, ale jeszcze nie zainstalowałem nowej wersji, którą proponujesz, gdyż rozkminiam, zgodnie z sugestią, czy mój szablon nie ma, niestety nigdzie nie widzę, jest jednak taka opcja w ustawieniach tematu DIVI –opcje szablonów graficznych → integracja → i tu puste kole, obok którego pisze dodaj kod do obszaru < body > (dobry do śledzenia kodów, np. Google Analytics)

    a tu link do całej stronki, gdzie jest opis wszystkich ustawień DIVI
    http://www.elegantthemes.com/gallery/divi/documentation/theme-options/

    ja włączyłem tłumaczenie tej strony na język polski, no i do tej opcji, którą podaje jest na samym dole tłumaczenie takie:
    dodaj kod do obszaru < body > (dobry do śledzenia kodów, np. Google Analytics)
    Każdy kod umieścić tutaj pojawi się w sekcji treści wszystkich stron bloga. Jest to przydatne, gdy trzeba wprowadzić piksel śledzenia stanu licznika, takich jak Google Analytics.

    Jeśli chodzi o główny problem z wpisem, który poruszam w tym poście, to przyznam się szczerze, że póki co nie rozumiem, nie wiem jak mam zrobić to co sugerujesz (?) Jak wejść w FTP, jak skopiować plik, itd. możesz to napisać jaśniej?

    Tak, tam możesz dodać kod od analyticsa. Zobacz dzień lub dwa po, czy dobrze zlicza, jeśli nie, to przeklej do <head>.

    Pomiń krok z ftp i wykonaj punkty 2 oraz 3.

    Niestety, po umieszczeniu kodu w body w ogóle nie zlicza, jak przekleiłem do <head> również nic się nie dzieje

    Podobnie z głównym problemem widoczności wpisu, wykonałem punkty 2 i 3 i żadnego skutku, jak ustawiam wpis w opcji, „bez kategorii” to wpis jest widoczny, jak wpisuje kategorię wpis znika, ale po wejściu w temat w kategorie fizycznie tam jest 🙁

    W ustawieniach czytania co masz tak w ogóle ustawione?

    Co do analytics – zainstaluj sobie plugin, o którym wspominałem.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Nie widać dodanego wpisu, szablon DIVI’ is closed to new replies.