Wsparcie » Wtyczki » NIe działaja pluginy galerii

  • Gdy próbuje dodać jakikolwiek plugin galerii (spróbowałam dobre pięć lub więcej) otrzymuje błąd:

    Notice: wp_enqueue_style was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/users/dan87sul/public_html/fototrendy.com.pl/wp-includes/functions.php on line 3897

    Dodatkowo, gdy plugin galerii jest włączony, nie mogę dodawać mediów.

    Próbowałam wyłączyć wszystkie inne pluginy. W function.php wy-komentowałam wszystkie linijki w których dodawałam css i js-y. Nie pomaga.

    Nie wiem co jeszcze mogę zrobić, jakieś pomysły?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Masz źle wywołane wp_enqueue_style, błąd wyraźnie o tym mówi; więcej informacji jak „zrobić to odpowiednio”:
    http://wordpress.stackexchange.com/a/137108

    Dwa – z konsoli css od bootstrapa wyrzuca 404, więc też jest źle wywołany.

    • Ta odpowiedź została zmodyfikowana 4 years, 10 months temu przez Nikodemsky.
    Thread Starter eFKa13

    (@efka13)

    Jeżeli dobrze zrozumiałam, to są tam dwie porady: pierwsza dotyczy kolejności dodawania wpisów w function.php, a druga, żeby z różnych metod dodawania css i js wybrać wp_enqueue_ (ja używałam (wp_reqiater_) , ale nic mi to nie pomogło. Zresztą nie dziwi mnie to, ponieważ próbowałam już wcześniej wyciąć wszystkie dodawane przez mnie skrypty i css i nic to nie pomogło. Wywaliłam zupełnie wszytko, co miałam w function.php i header.php (doty. js i css) i nic. W momencie dodawania jakiegokolwiek plugina galerii klapa. Gdy nie dodaje pluginów galerii wszytko śmiga pięknie.

    Bootstampa dodaje poprzez plugin bootstamp shorcode i jest to chyba najlepsza metoda? Tak, miałam jeszcze dodawanie w function.php, ale już się ich pozbyłam, bardzo dziękuje za tę uwagę…

    Co więcej: w momencie gdy pozostawię tylko prawie pusty index.php i style.css oraz folder z grafikami mam dokładnie ten sam błąd. Więc nie wiem nawet gdzie miałabym szukać tych niepoprawnie dodanych wp_enqueue_

    Czyli jak na razie nic mi nie pomogło 🙁 Co to może być? I dlaczego tylko pluginy galeri?

    • Ta odpowiedź została zmodyfikowana 4 years, 10 months temu przez eFKa13.
    • Ta odpowiedź została zmodyfikowana 4 years, 10 months temu przez eFKa13.

    Bootstrapa najlepiej dodawać ręcznie, a najlepiej tylko elementy z niego potrzebne, żeby uniknąć konfliktów. Przynajmniej według mnie.

    Możesz wrzucić swój plik functions.php już z dodanymi kodami stylów?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘NIe działaja pluginy galerii’ is closed to new replies.