Wsparcie » Uwagi » Możliwość aktualizacji do bieżącej wersji językowej

  • Wydaje mi się ze przydała by się taka funkcja – aby z automatu (kokpitu) można było zaktualizować wordpressa do ostatniej skończonej wersji językowej a nie tak jak jest teraz, że pojawiająca się nowa wersja angielskojęzyczna defacto blokuje wiele osob przed wykonaniem aktualizacji do momentu kiedy to nie wyjdzie odpowiednie wydanie jezykowe.

    W przykładzie na dzień dzisiejszy: jest mozliwość zaktualizowania wordpressa do anglojęzycznej wersji 3.5.1 oraz aby byla możliwośc zaktualizowania się do polskiej wersji 3.5 bo to ona byla ostatnia zrobiona.

    Oczywiście ja sobie zdaje sprawę, że można aktualizacje ręcznie ściągnąć i wykonać ale nie wszystkie osoby mają takie umiejętności, a i czasem nie mają np. dostępu do plików.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Ale to raczej nie powinien być problem, jeśli aktualizujesz WordPressa na bieżąco – a tak właśnie powinieneś…

    To trzeba raz jeszcze wyjaśnić, bo wiele osób ma co do tego jakieś dziwne obawy:

    Jeżeli zainstalowałeś WP w jego źródłowej wersji PL, to po aktualizacji język się NIE ZMIENIA.

    BTW – warto się uczyć angielskiego 😉

    🙂 „dziwne obawy” zazwyczaj skas sie biora. W moim przypadku z tego co widze w panelu administratora czyli np. osobny przycisk na aktualizacje angielska i osobny przycisk na aktualizacje polska oraz napis „Zamierzasz zainstalować WordPressa 3.5.1 w angielskiej (amerykańskiej) wersji językowej. Istnieje ryzyko, że po wykonaniu aktualizacji używane przez Ciebie tłumaczenie przestanie działać. Jeśli chcesz, możesz poczekać, aż wydana zostanie paczka z tłumaczeniem.”

    Przyznaje sie, ze nie probowalem aktualizowac polskiego wordpressa angielskim uaktualnieniem no ale logicznie rzecz ujmujac skoro nie mialo by wplywu na jezyk tak jak mowisz to po co bylby ten podzial i ostrzezenie.

    Wynika to raczej z pewnych przeświadczeń i wewnętrznych przekonań… dotyczących j.angielskiego… itd.
    Ale analiza zachowań nie jest teraz na miejscu.

    @czester, jak już wspominali Krzysiek i Paweł, nic nie stoi na przeszkodzie by aktualizować wersją EN.
    Wersja EN to po prostu pakiet pozbawiony plików językowych – ot nie zostaną one nadpisane przy aktualizacji bo niby czym?
    -tak więc przy aktualizacji język nie ginie, jeżeli miałeś PL to będzie nadal.

    Co do ostrzeżenia, to jest ono z tego względu, że w przypadku małych aktualizacji zmiany są raczej kosmetyczne. Jeżeli aktualizujesz na bieżąco, to najwyżej dojdzie ci kilka linijek nieprzetłumaczonych.
    Ale jak przyjdzie ci dajmy na to głowy robić upgrade z wersji < 3.1 do najnowszej, to już różnic między nimi może być tyle, że stare tłumaczenie po prostu przestanie spełniać swoją funkcję.

    Co do ostrzeżenia, to jest ono z tego względu, że w przypadku małych aktualizacji zmiany są raczej kosmetyczne. Jeżeli aktualizujesz na bieżąco, to najwyżej dojdzie ci kilka linijek nieprzetłumaczonych.

    To jakaś bzdura. Od ilu „linijek nieprzetłumaczonych” zaczyna się uszkodzona instalacja? Moja odpowiedź brzmi: od jednej.

    Prawdziwym problemem są karygodne opóźnienia wydawania spolszczeń. Nie do wiary, że 3.5.1-PL wciąż nie ma. To ponoć kilka linijek?

    Prawdziwym problemem są karygodne opóźnienia wydawania spolszczeń. Nie do wiary, że 3.5.1-PL wciąż nie ma. To ponoć kilka linijek?

    Nie ma zmian językowych między wersją 3.5 a 3.5.1 więc nie ma parcia na taką wersję.

    Ale czy sa zmiany jezykowe czy nie, badz czy sa one duze czy male wie niewiele osob. Dodajac do tego stwierdzenie:

    Nie ma zmian językowych między wersją 3.5 a 3.5.1 więc nie ma parcia na taką wersję.

    Dochodzimy do tego iz przez poltorej czy 2 miesiace nikomu nie chcialo sie zamiescic linka do polskiej wersji – bo tlumaczyc przeciez nie trzeba bylo.

    Obstawiam dalej iz najprosciej by bylo to co napisalem w pierwszym poscie.

    Dochodzimy do tego iz przez poltorej czy 2 miesiace nikomu nie chcialo sie zamiescic linka do polskiej wersji – bo tlumaczyc przeciez nie trzeba bylo.

    Czy zdajesz sobie sprawę, że osoby tłumaczące oraz osoba odpowiedzialna za wypuszczanie wersji PL pracuje całkowicie za darmo? W związku z tym jakiekolwiek roszczenia czy pretensje są po prostu bezpodstawne.

    Rozumiem ze w twoim przekonaniu jak ktos robi cos za darmo to moze to robic zle lub niedokladnie – ja jakos zawsze inaczej rozumialem zasade wolontariatu.

    Co ciekawe zawsze sa odpowiedzi tylko nie na pytania postawione. Temat tu zalozony mial wlasnie te osoby chronic przed trudnymi pytaniami czy cos pracuja czy nie a zwyklym userom dac spokoj.

    Jak w panelu admina widac by bylo ze jest mozliwosc automatycznej aktualizacji angielskiej wersji do 3.5 a polskiej do 3.3 to bym nic nie mowil. Tylko ze nie ma, jak wersje nie sa te same to mozna sobie aktualizowac tylko angielska, co przy jakims tam pechu moze sie okazac ze polska nadgoniona wersja powisi dzien czy dwa bo znowu wyjdzie nowsza wersja angielska itd.

    Rozumiem ze w twoim przekonaniu jak ktos robi cos za darmo to moze to robic zle lub niedokladnie – ja jakos zawsze inaczej rozumialem zasade wolontariatu.

    Mylisz pojęcia. Bardzo.

    1. Nie ma żadnego wolontariatu. – wolontariat to umowa o pracę bez wynagrodzenia, gdzie pracodawca zwraca ponoszone koszty. WP jest tłumaczony za darmo w idei OpenSource.
    2. Jeżeli uważasz, że tłumaczenie jest wykonane źle lub niedokładnie, to wskaż takie miejsca.

    Marcin,
    Myślę, że to kwestia skrótów myślowych.

    Uwag tych nie bierz też raczej do siebie.

    Natomiast trzeba przyznać, że jak na dość sporą społeczność WP, to z tempem tłumaczeń nie jest najlepiej. I tak, ja zdaję sobie sprawę z tego, że to tak naprawdę nie jest problem (bo spokojnie można aktualizować do wersji en), ale zwykłych użytkowników ten brak odpowiedniej paczki po prostu gubi (i moim zdaniem to nie jest ich wina) i zniechęca do szybkiego aktualizowania.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Możliwość aktualizacji do bieżącej wersji językowej’ is closed to new replies.