Wsparcie » Używanie i konfiguracja WordPressa » mozilla wyrzuca mnie z panelu wp-admin

  • Rozwiązano specbabka

    (@specbabka)


    Wczoraj miałam ogromy problem ze stroną, po zainstalowaniu wtyczki wp cache utraciłam całą stronę, nic się nie pokazywało w przeglądarce (tabula rasa), nawet nie miałam jak się zalogować. Nagimnastykowałam się kilkanaście godzin aby przywrócić wszystko. Dzięki pomocy na forum oraz zabezpieczonym danym na hostingu wszystko wróciło.. ale mam inny problem. Sama strona działa chyba ok (strony, podstrony, linki), natomiast w momencie zalogowania do wp-admin w przeglądarce mozilla wywala mnie po 4 sekundach. Na explorerze jest ok, ale korzystam z mozilli i będę wdzięczna, jeśli podpowiecie mi, co może być przyczyną.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Moderator amistad18

    (@amistad18)

    Wyczyść wtedy ciacha, itd w przeglądarce, w Mozilli to było chyba ctrl + shift + del.

    Thread Starter specbabka

    (@specbabka)

    Dzięki! Wyczyściłam, ale lipa, nic nie dało.. Czy jest możliwość, że może być to związane z jakimiś pustymi wersami np w pliku functions.php? podkreślam, że w explorerze działa ok

    Czy to się też dzieje jak masz wyłączony moduł cache’ujący?

    Być może to nie ma nic wspólnego z WP. Ja bym sprawdziła jeszcze w innej przeglądarce, np. Operze, Chromie, Safari.

    Być może Twój Firefox ma ustawione automatyczne kasowanie cookiesów, czyszczenie cache’a po upłynięciu jakiegoś czasu i stąd ten automatyczny log out. Tak może dziać, jeśli Firefox działa w trybie private browsing box

    P.S. Ciesze się, że na tym forum pisze jeszcze jakaś babka. Piszesz, że uprzednio straciłaś całą stronę. Ja każdą stronę oficjalną prowadzę podwójnie: jedną w wersji testowej (treści są atrapami, uproszczone, strona wyłączona z indeksowania Google’a itd.), drugą już normalnie LIVE. Każdą jakaś poważniejszą zmianę najpierw aplikuję na stronie testowej, jak działa, przerzucam na LIVE.

    private browsing mode miało być

    Thread Starter specbabka

    (@specbabka)

    czesc Agabu! dzięki za posta i rady. Byłam kilka dni offline, więc tak późno reaguję.. Ta druga rada naprawdę przydatna, chętnie zastosuję tą samą technikę co do swoich stron. Natomiast co do kwestii wywalania z firefoxa, to musi być coś innego. Próbowałam zalogować się na różnych komputerach korzystając z firefoxa i zawsze jest to samo – loguje się na 2 sekundy, a potem wywala. Sprawdzałam ustawienia i chyba nie mam trybu private browsing mode.. No i stało się to wtedy, gdy hosting przywrócił bazę i pliki strony

    Sprawdź no jeszcze w jakiejś przeglądarce. Np. Chromie lub Operze. Wtedy będziemy mieć pewność, czy na pewno jest to tylko związane z firefoksem.

    Thread Starter specbabka

    (@specbabka)

    OK! właśnie instaluje operę. Natomiast mam drugą stronę w wp z inną bazą i nie mam problemu z zalogowaniem na admina z firefoxa

    Thread Starter specbabka

    (@specbabka)

    W Operze dzieje się to samo, co firefoxie. A więc na wp-admin wywala mnie po 3 sekundach. Jednak jeśli zaloguje się nie na sam kokpit, a np na zarządzanie wpisami,a więc wp-admin/edit.php albo themami, a więc wp-admin/themes.php jest ok, i w Operze, i w firefoxie. Nie znam się na php, ale czy może mieć to jakieś znaczenie?

    OK, to już wiemy, że to nie problem ustawień Firefoksa.

    Sprawdź no jeszcze, co masz podane w Ustawienia->Ogólne w polach „Adres URL WordPressa” oraz „Adres witryny (URL)”. Czy dokładnie to samo, np. jeśli nawet masz w jednym URL bez www, a w drugim z www, to znaczy że nie jest to samo. To może (ale nie musi) być przyczyną automatycznego wylogowywania.

    Thread Starter specbabka

    (@specbabka)

    Dzięki Agabu. A więc muszę zaznaczyć, że mam zainstalowane MultiSite i buddypressa. Tych ustawień, o których piszesz już nie mam w w ogólnych ustawieniach. U mnie wygląda to trochę inaczej. Jednak aby uruchomić MultiSite na początku musiałam ujednolicić nazwy obu adresów. W zasadzie jest tak:
    Uruchomiłam multisite i buddypressa na dwóch odrębnych swoich witrynach. Na obu działało dobrze, na tej obecnej, ważniejszej stronie rozjechało się, gdy zainstalowałam tam wtyczkę WP Super Cache, która ingeruje w skrypty PHP (myślę, że tu leży jakiś problem). Padło mi wówczas wszystko. I to cud, że odzyskałam bazę i pliki z powrotem. Już nie mam tej wtyczki, jednak wydaje mi się, że mój problem to skutek uboczny.

    To już wyczerpały mi się pomysły. Szukałam w necie pod hasłami „wordpress keeps logging me out” itp., zwykle w rozwiązaniach sugerują, że to może mieć coś wspólnego z cookie’sami i time outem sesji, albo właśnie z niezgodnością w URL-ach w bazie. U Ciebie ani jedno ani drugie się nie potwierdziło. Może to faktycznie ma coś wspólnego z hostingiem i tą akcją, co się wydarzyła.

    Moderator amistad18

    (@amistad18)

    To ja mam dwa pomysły.

    1. Unikalne klucze w wp-configu uzupełnione? Oraz wszystkie? Trochę ich tam jest, i z nowszymi wersjami WP zaczynało ich przybywać.

    2. Spróbuj 'obok’ postawić WP. Po instalacji w ustawieniach zmień adres strony i bloga na taki sam jaki jest na tej stronie co nie działa. Później w starym pliku wp-config.php zmień dane do bazy – wskazując na tą nową. Jak będzie działało, to po kolei uruchamiaj MU, Buddypress, później szablon i wtyczki – aby tą drugą bazę jak najbardziej upodobnić do obecnie niedziałającej poprawnie.

    Thread Starter specbabka

    (@specbabka)

    Dzięki Agabu za wytrwałość i stawanie na głowie, dzięki Amistad18 za pomysł! Wypróbuję wersję nr 1., no ale podejrzewam, że będę zmuszona do wersji nr 2 😀 tak więc uważam temat za rozwiązany, pozdrawiam!

    Thread Starter specbabka

    (@specbabka)

    PS. ostatecznie doszłam do tego, że w 99% to wina hostingu! HOME.PL!

    Thread Starter specbabka

    (@specbabka)

    ROZWIĄZANIE: chodziło o to, że usłudze hostingowej (HOME.PL) są automatyczne statystyki oglądalności stron itp itd, dopisują skrypt zliczający do kodu strony, można je wyłączyć. Działa już wszystko prawidłowo! tak więc nieco mi głupio, że męczyłam Was, zamiast od razu uderzyć do tych od serwera. Jednak mimo wszystko, Wasze rady będą cenne na inne „wypadki”

Viewing 15 replies - 1 through 15 (of 18 total)
  • Temat ‘mozilla wyrzuca mnie z panelu wp-admin’ jest zamknięty na nowe odpowiedzi.