Wsparcie » Wtyczki » Mapa google pola użytkownik

  • Rozwiązano Rayu85

    (@rayu85)


    Witam,
    Niedawno pytałem o pola użytkowników, udało nam się wspólnie dojść do tego jak to działa 🙂 teraz chciałbym wykorzystać to przy mapach google.
    Mianowicie mam stworzony szablon wpisu i w nim bym chciał umieścić mapę google która będzie się pojawiać w każdym wpisie tylko chciałbym aby mapa dla każdego posta pokazywała inny adres (zdefiniowany w polach użytkownika)

    Próbowałem stworzyć mapę z adresem [acf field=”adres”] ale nie przyjmuje takiego adresu wtyczka:(

    Jak coś takiego zrobić?:)

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Rayu85

    (@rayu85)

    Dzięki za kolejną fajną wtyczkę ale mam problem:(
    mianowicie w instrukcji jest
    „2.Utwórz pole mapy – jako rodzaj pola wybierz Google Map
    3.Nadaj mu nazwę, np. nazwa_pola”
    ale po zainstalowaniu nigdzie w panelu nie widzę żadnych ustawień ani niczego:(

    Gdzie mam to pole utworzyć?

    Thread Starter Rayu85

    (@rayu85)

    ok udało mi się znaleźć jak już tworzyć to pole ale mapka się nie wyświetla. W polu użytkownika w jakiej formie powinienem podać dane? po prostu adres czy jakieś dane z google maps?

    Thread Starter Rayu85

    (@rayu85)

    widzę że przy edycji posta pojawiła się mapka. Wyszukuję adres ale po aktualizacji postu wyglada jakby nadal było pusto (jakby nie zapisywał adresu.

    Co robię źle?

    Thread Starter Rayu85

    (@rayu85)

    Sorka że tak monologuję ale udaje mi się iść do przodu.
    wpis w polu mapki przestał znikać w momencie gdy adres wpisałem ręcznie a nie wkleiłem ale nadal mapka się nie wyświetla:(

    Pole mapa tworzysz w Advanced Custom Fields.

    W treści wpisu (lub w szablonie, jeśli używasz WPnet.pl Templates) wpisujesz shortcode
    [gmap-display field=”nazwa_pola”]
    Mapa wyświetla się tylko wtedy, gdy dany wpis ma zaznaczony punkt na mapie.

    Thread Starter Rayu85

    (@rayu85)

    kurcze no to tak robię i nie wyświetla mi się nic 🙁
    Co może być przyczyną?
    Korzystam z WPnet.pl

    Możesz podać adres strony?
    Ewentualnie proszę o kontakt mejlowy (info@wpnet.pl)

    Trzeba zwrócić uwagę na cudzysłowy
    – muszą być proste („), a nie (”), np.
    [gmap-display field="nazwa_pola"]

    Thread Starter Rayu85

    (@rayu85)

    dzięki za pomoc:) udało się rozwiązać problem był w cudzysłowach 🙂

    Odświeżę temat.

    Użyłem tej samej wtyczki, nie ma praktycznie żadnych problemów jeżeli chcę wyświetlić mapkę we wpisie, czy też na stronie. Ja utworzyłem własne pole na stronie, w wyskakującym okienku – bootstrap. I tu jest problem. Pokazuje mi się tylko szare tło, a jak przybliżę to przez ułamek sekundy coś widać po czym ponownie wraca do szarego koloru. Logo google maps widać;) Czy ktoś wie o co chodzi, coś podobnego ktoś miał?

    Czy możesz podać adres strony?

    Przepraszam za zwłokę – sylwester, urlop i ferwor życia…odpuściłem bootsrapa i wszystko chodzi. Wyglądało to tak jakby się skrypty ze sobą gryzły. Nie wiem czy to jest oczywiście możliwe, ale zanim dostosowałem bootstrapa do worpdressa to się ze stylami szablonu gryzł i cały dizajn mi rozwalał.

    Pozdrawiam.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Temat ‘Mapa google pola użytkownik’ jest zamknięty na nowe odpowiedzi.