Wsparcie » Używanie i konfiguracja WordPressa » Linki otwierające wpisy nie działają, nie da się dodać nowych wpisów

  • Rozwiązano NoweSimsy

    (@nowesimsy)


    Witam,
    dziś zauważyłam na mojej stronie NoweSimsy.pl taki problem.
    Na stronie głównej, jak i po otwarciu archiwum i kliknięciu w tytuł wpisu nie przekierowuje mnie do niego tylko odświeża stronę główną/stronę archiwum. Ze stronami z menu nie ma problemu, przekierowuje dobrze.
    Próbowałam kilkakrotnie w ustawieniach zmienić bezpośrednie odnośniki na różne wartości i nic – zmieniały się oficjalnie (gdy edytuję, tam nad tekstem link pojawia się dobry, także po wpisaniu ręcznym adresu /nazwa, wpis jest otwierany.
    Nie działa natomiast automatyczne przekierowywanie.
    Do tego wszystkiego gdy próbuję dodać nowy wpis nie mogę go opublikować na stronie, jedyne dwie opcje to szkic i oczekuje na przegląd.
    Rzeczy, które ostatnio zmieniałam to dodanie podstrony, wrzucenie nowych obrazków do mediów strony oraz instalacja wtyczki gallery, która i tak nie działała, więc ją wyrzuciłam oraz instalacja wtyczki Google Analytics Dashboard for WP w wersji 4.2.
    Poza tym dziś chciałam naprawić to aktualizacją wordpressa do najnowszej wersji i nic to nie dało:(
    Bardzo proszę o pomoc!
    Pozdrawiam

Viewing 12 replies - 1 through 12 (of 12 total)
  • A nie grzebałeś przypadkiem w plikach motywu?
    …zobacz jak wygląda tytuł wpisu

    <h2>
              <a href=""
                http://nowesimsy.pl/nowe-grafiki/" rel="bookmark" title="Permanent Link to Nowe grafiki z gry">Nowe grafiki z gry          </a>
            </h2>

    -przy href masz o jeden cudzysłów za dużo, więc albo coś tam sobie edytowałeś, albo nieco mniej prawdopodobne – jakaś wtyczka bruździ.

    Thread Starter NoweSimsy

    (@nowesimsy)

    Dziękuję bardzo na nasunięcie mi rozwiązania:)
    Najprawdopodobniej to wina wtyczek, bo w indexie wcale nie grzebałam
    dziękuję bardzo jeszcze raz, problem rozwiązany:)

    Thread Starter NoweSimsy

    (@nowesimsy)

    Ale niestety problem braku możliwoci dodania wpisu pozostał:(
    W jakim pliku mógł wystąpić błąd uniemożliwiający dodanie wpisu na stronie? Jest tylko szkic i przegląd, nie ma opublikowano, po kliknieciu opublikuj, zapisuje jako szkic.
    Nie wiem co za wtyczka to zrobiła ale teraz chyba nie będę instalować żadnej..

    Może jesteś na koncie z niższymi uprawnieniami? Albo bawiłeś się jakimiś wtyczkami do zarządzania uprawnieniami użytkowników?

    Thread Starter NoweSimsy

    (@nowesimsy)

    Niestety nic z tych rzeczy:(
    Używam tylko tej wtyczki do statystyk i chciałam do galerii ale się nie udało, więc zrezygnowałam
    Na stronce jest tylko jeden użytkownik – tzn. admin czyli ja więc na pewno nie mogę być zalogowana na innego użytkownika.
    Próbowałam usuwać ciasteczka i też nic

    użytkownik może być jeden, i może to być admin, administrator czy jak tam jeszcze kto chce ….ale może nie mieć uprawnień.
    Sprawdź w bazie danych np. za pomocą PhpMyAdmin’a ..TABELA wp_usermeta, pole wp_capabilities powinno mieć wartość a:1:{s:13:”administrator”;s:1:”1″;}
    albo a:1:{s:13:”administrator”;b:1;}
    -jeżeli jest coś innego, zmień na któreś z powyższych, przeloguj się i sprawdź

    Thread Starter NoweSimsy

    (@nowesimsy)

    Niestety to się zgadza, u mnie wygląda to tak: wp_capabilities a:1:{s:13:”administrator”;b:1;}, czyli tak jak w drugim przykładzie..

    A czy może to być cos w tekście skryptu strony?Tak jak poprzednie? W niczym nie grzebałam, któras wtyczka mi tak namieszała, że nie wiem co się tam dzieje teraz na tej stronie..

    ??? -któż to może wiedzieć.

    Zmień motyw na inny, czysty i niemodyfikowany – najlepiej jeden z serii Twenty …i sprawdź czy problem nadal występuje. Jeżeli nie – masz odpowiedź, że winny motyw …a co i w którym miejscu, to już pewnie debugować albo przysiąść i porównywać z oryginałem.

    Thread Starter NoweSimsy

    (@nowesimsy)

    Zmieniłam szablon, oczyściłam ciasteczka, od nowa się zalogowałam i problem niestety nadal występuje

    Moderator amistad18

    (@amistad18)

    Jak przełączenie motywu nie pomaga, to spróbuj jeszcze wyłączyć wszystkie wtyczki. Jeżeli masz uprawnienia admina, to podobnie jak adpawl, obwiniał bym albo szablon albo wtyczki.

    Thread Starter NoweSimsy

    (@nowesimsy)

    Jakimś dziwnym sposobem strona naprawiła się sama po kilkunastu dniach – z tym że nie na firefoxie – i to nie tylko na moim komputerze na firefoxie nie mogę opublikować posta.
    Ważne, że sprawa jakoś sama się rozwiązała, denerwujące jest tylko to zmienianie przeglądarki przy każdej publikacji…

    Dziękuję za pomoc w każdym razie 🙂

    jacekblaumann

    (@jacekblaumann)

    a ja mam ten sam problem tylko że oprócz tego nie da się zmienić motywu, nie da się też włączyć ani wyłączyć żadnej wtyczki. nie da się nic opublikować, jest tylko guzik zapisz do przeglądu. nie pomaga usunięcie pluginów ręcznie z serwera.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Temat ‘Linki otwierające wpisy nie działają, nie da się dodać nowych wpisów’ jest zamknięty na nowe odpowiedzi.