Wsparcie » Używanie i konfiguracja WordPressa » Konfig. domeny – Nie pokazuje domeny tylko katalog

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator amistad18

    (@amistad18)

    Ustawienia > ogólne

    I tak na przyszłość. Ktoś kto się bawi we własnego hostowanego WP, ze średnim doświadczeniem, powinien wiedzieć takie rzeczy, przecież to jest podstawa, zapoznać się z panelem administracjnym … a tym bardziej ktoś kto przyjmuje zlecenie od klienta na stronę, i nie zna podstaw. Trochę to takie nieprofesjonalne 'uczyć się' na stronach klientów 😉

    Dzięki za pomoc, jednak tam nie odnajduję tego co potrzeba.
    Widzę opcję pokroju nazwa witryny, daty, timezony itp. Sam myślałem, że w wp-config a konkretnie:

    $base = '/oneword/';
    define( 'DOMAIN_CURRENT_SITE', 'junx.2box.pl' );
    define( 'PATH_CURRENT_SITE', '/oneword/' );

    Jest odpowiedzią jednak chyba nie do końca…

    ps:
    Nie jestem etatowym code’rem i nie jest to moją odpowiedzialnością jednak przypadek losowy/świąteczny zmusza do ogarnięcia problemu stety/niestety 😉

    Jeszcze raz dzięki za odp. i był bym wdzięczny za dalszą sugestię.

    Moderator amistad18

    (@amistad18)

    Ominąłeś najważniejsze:
    Adres URL WordPressa
    Adres witryny (URL)

    Ale jeżeli to nie działa, i żeś nakombinował w wp-config.php, to ciężko będzie Ci pomóc, dlatego proponuję poczekać na swojego webmastera, a tymczasem cieszyć się świętami.

    http://junx.2box.pl/wordpress.jpg – nie ma takiej opcji w miejscu o którym mówisz stąd moje zdziwienie.

    Niestety czekanie nie wchodzi w grę – było by to nieprofesjonalne 🙂
    w configu nic nie jest namieszane – standardowe kroki podczas instalacji sieci. Będę wdzięczny za ponowny rzut okiem i odniesienie się do tego co napisałem.

    Pozdrawiam serdecznie.

    Moderator amistad18

    (@amistad18)

    Heh, skoro się nie wyświetla, to chyba jednak namieszane. Wrzuć w tagach code twój wp-config.php, login i hasło do bazy możesz sobie zagwiazdkować czy wywalić.

    <?php
    /** Nazwa bazy danych Twojego WordPressa */
    define('DB_NAME', '');
    
    /** Nazwa uzytkownika bazy danych MySQL */
    define('DB_USER', '');
    
    /** Haslo do bazy MySQL */
    define('DB_PASSWORD', '');
    
    /** nazwa hostu MySQL */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**
     * Prefiks bazy danych WordPress.
     */
    $table_prefix  = 'wp_';
    
    /**
     * Wersja jezykowa WordPress (pl_PL dla polskiego)
     */
    define ('WPLANG', 'pl_PL');
    
    define('WP_ALLOW_MULTISITE', true);
    
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/oneword/';
    define( 'DOMAIN_CURRENT_SITE', 'junx.2box.pl' );
    define( 'PATH_CURRENT_SITE', '/oneword/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    define( 'AUTH_SALT', '' );
    define( 'SECURE_AUTH_SALT', '' );
    define( 'LOGGED_IN_SALT', '' );
    define( 'NONCE_SALT'' );
    
    /* To wszystko, mozesz skonczyc edytowac. Polska Dystrybucja WordPress zyczy Ci milego blogowania! */
    
    /** Absolutna sciezka dostepu do katalogu WordPress. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Do ustawien WordPress. */
    require_once(ABSPATH . 'wp-settings.php');

    Tak by to wyglądało – zasadniczo poza tym co przy instalacji sieci było wskazane by dodać to nic „swojego” nie wprowadzono. Dziwna sytuacja.
    Będę wdzięczny. Pozdr.

    Moderator amistad18

    (@amistad18)

    Hmm, chyba jednak Ci nie pomogę, tutaj trzeba by było mieć dostęp do serwa i do bazy, i trochę się pobawić.

    west28

    (@west28)

    pokazuje to co masz skonfigurowane w zmiennych:

    $base = '/oneword/';
    define( 'DOMAIN_CURRENT_SITE', 'junx.2box.pl' );
    define( 'PATH_CURRENT_SITE', '/oneword/' );

    generalnie robi się to inaczej. DNS domeny ustawiasz na katalog oneworld. wp zaś konfigurujesz, aby wyświetlał, że jest w katalogu głównym domeny czyli

    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'junx.2box.pl/oneworld' );
    define( 'PATH_CURRENT_SITE', '/' );

    gentleweb

    (@gentleweb)

    Problem polegał na tym po prostu, że multisite został zainstalowany w podkatalogu – stąd problem z poprawnym wyglądem. Problem nie istnieje, gdy instalacja znajduje się w głównym katalogu na serwerze a nie podkatalogu.
    Podczas instalacji multisite wspominają o instalowaniu w głównym katalogu – myślałem jednak, że ma to wpływ na inną rzecz niż ta o której tutaj pytałem.
    Pozdrawiam serdecznie.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Konfig. domeny – Nie pokazuje domeny tylko katalog’ is closed to new replies.