Wsparcie » Motywy » Kilka wyrazów w szablonie nie tłumaczy się!

  • Hej, mam problem z tłumaczeniem!

    Nie wiem czemu ale kilka pojedynczych wyrazów nie chcą się przetłumaczyć. Sprawdzałem pliki po./mo. i tam jest wszystko ok. W pliku config.php też jest dobrze ustawione pl_PL. Próbowałem załatwić to inaczej, samodzielnie tłumacząc te wyrazy bezpośrednio w plikach php jednak nie znalazłem odpowiednich plików z tymi wyrazami.

    Nie wiem co mam robić, przeszukałem większość plików i nic.
    Mogę dać dostęp abyście mogli zobaczyć co jest nie tak. Szablon nie jest standardowy.

    Te słowa to:

    Comments are closed.
    One comment on
    Reply
    Mr WordPress on 20-01-2012 at 2:47 said

    Proszę o pomoc!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Obstawiałbym, że:
    a) mimo wszystko jednak w plikach .po/.mo nie jest to zrobione prawidłowo,
    b) frazy te nie korzystają z domeny tłumaczeń motywu, tylko innej.

    Dzięki za odpowiedź. Znajomy podpowiedział mi aby nie tłumaczyć samodzielnie w poszczególnych plikach. Przywróciłem wszystko do dawnego stanu i dodałem do thema plik pl_PL (wcześniej był inny) i zadziałało.

    Zauważyłem, że jeden wyraz się nie tłumaczy. Tzn. w pliku po. jest tyle że odwołanie jest przypisane do czegoś innego. Da się jakoś dodać odwołanie?

    Generalnie tak:

    1. Raczej nie powinno się tłumaczyć bezpośrednio w plikach, bo się wtedy odcinasz od aktualizacji i od mechanizmu tłumaczeń.

    2. Jeśli jakieś słowo się nie tłumaczy, to należałoby sprawdzić, czy w plikach motywu/wtyczki jest drukowane poprzez mechanizm tłumaczeń, czy wstawione „na chama”. W drugim przypadku trzeba je przepuścić przez tłumaczenia. W pierwszym trzeba sprawdzić poprawność plików .po i to, czy masz wygenerowany plik .mo (i czy jest on aktualny).

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Kilka wyrazów w szablonie nie tłumaczy się!’ is closed to new replies.