• Rozwiązano pit-lol

    (@pit-lol)


    Natknąłem się na duży problem z edytowaniem zdjęć. Po prostu nie wyświetlają się one w panelu edycji mediów i nie można ich ani obracać ani, co najważniejsze, kadrować.

    Jestem pewny, że problemem jest plik functions.php, bo gdy tylko usuwam plik – problem od razu znika. Niestety nie jest to związane w żaden sposób z białymi znakami po znaczniku ?>, bo problem występuje nawet kiedy plik functions.php jest PUSTY. To na prawdę dziwne, bo niezależnie od włączonych wtyczek wystarczy tylko utworzyć pusty plik functions.php, by możliwość edycji obrazków znikła.

    Liczę na Waszą pomoc, bo szczerze mówiąc nie wydaje mi się, żebym po tylu próbach mógł sam rozwiązać ten irytujący problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Jesteś pewien, że Twój plik functions.php jest zapisany w UTF-8 bez BOM? Sprawdzałeś co ciekawego trafia do konsoli błędów przeglądarki po otwarciu panelu edycji mediów?

    Thread Starter pit-lol

    (@pit-lol)

    Ogromne dzięki za pomoc!

    Z ciekawości muszę Cię zapytać dlaczego plik sformatowany jako UTF-8 bez BOM działa poprawnie i czy wszystkie pliki .php w swoim motywie powinienem kodować właśnie bez BOM?

    BOM to trzyznakowy znacznik (niewidoczny w edytorze), który w przypadku skryptów czy dokumentów HTML jest całkowicie zbędny. Jak widzisz, sprawia on tylko problemy, tak więc zawsze powinieneś zapisywać pliki w UTF-8 bez BOM.

    Thread Starter pit-lol

    (@pit-lol)

    Niestety wygląda na to, że cieszyłem się zbyt wcześnie. Pomimo że na maszynie lokalnej wszystko działa jak należy, to już po wrzuceniu na serwer problem występuje. Jednak teraz problemem jest tylko brak możliwości kadrowania. Po wybraniu obszaru przycisk odpowiadający za przycięcie zdjęcia jest po prostu nieaktywny (szary).

    Konsola w Chromie nie pokazuje, żadnych błędów. Nie jest to chyba również spowodowane żadną funkcją w functions.php bo usunięcie całej zawartości na serwer i wrzucenie pustego pliku nie eliminuje problemu.

    Oczywiście za Twoją radą zmieniłem już kodowanie wszystkich plików w motywie na UTF-8 bez BOM. 😉

    Thread Starter pit-lol

    (@pit-lol)

    Mój błąd – zmiana rozmiarów miniaturek (Ustawienia > Media) pomogła. Jeszcze raz dzięki za pomoc.

    Problem (mam nadzieję) rozwiązany.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Temat ‘Brak możliwości edycji obrazków (między innymi kadrowanie).’ jest zamknięty na nowe odpowiedzi.