• sir_kris

    (@sir_kris)


    1. Zainstalowałem wtyczkę Enhanced Media Library

    2. W „Ustawienia Mediów” zmieniłem katalog w którym chce przechowywać pliki (Przechowuj wysłane pliki w katalogu)
    domyślnie było wp-content/uploads, zmieniłem na wp-content/foto

    3. Wchodzę na Media/Biblioteka/Dodaj Nowe i wgrywam zdjęcie np. „picture.jpg”
    – niestety zamiast jego miniaturki widzę w bibliotece szare pole a w jego właściwościach widzę że adres URL to (..)/wp-content/uploads/picture.jpg
    – tymaczem poprawny adres to (..)/wp-content/foto/picture.jpg i wpisując to w przeglądarce wszystko działa

    zatem:
    – pliki wgrywama mi poprawnie do katalogu do którego chciałem
    – ale w bibliotece błędnie wyświetla ich ścieżkę URL

    PS. jak wgram przez FTP plik do katalogu „foto” to w ogólę mi go nie pokazuje w Bibliotece

Viewing 1 replies (of 1 total)
  • Kurdupel

    (@kurdupel)

    Nie jestem pewny, ale prawdopodobnie musisz zmienić link do folderu ze zdjęciami w bazie danych, w tabeli wp_options i znaleźć wiersz o nazwie upload_path i tam zmienić /folder/folder/domains/adres.pl/public_html/wp-content/uploads na końcówkę foto/ Przyznam jednak szczerze, że ja bym folderów nie zmieniał i pozostawił tak jak chce WordPress. Co to przeszkadza, że pliki znajdą się w folderze uploads?

    Jak wgrywasz zdjęcie przez FTP to WordPress tego nie widzi, bo plik nie został „zaindeksowany” przez bazę danych.

Viewing 1 replies (of 1 total)
  • Temat ‘Błędne źródło plików dla Biblioteki Mediów’ jest zamknięty na nowe odpowiedzi.