• Dzień dobry, mam problem z błędem krytycznym na stronie który pojawia się co jakiś czas,
    WordPress w wersji 5.9.2
    Aktualny motyw: Blossom Chic (wersja 1.1.0)
    Aktualna wtyczka: WooCommerce (wersja 6.3.1)
    Wersja PHP: 8.0.14

    Szczegóły błędu
    ===================
    Błąd typu E_ERROR został spowodowany w linii 648 pliku /strona/wp-content/plugins/woocommerce/includes/class-wc-install.php. Komunikat błędu: Uncaught TypeError: method_exists(): Argument #1 ($object_or_class) must be of type object|string, int given in /strona/wp-content/plugins/woocommerce/includes/class-wc-install.php:648
    Stack trace:
    #0 /strona/wp-content/plugins/woocommerce/includes/class-wc-install.php(648): method_exists()
    #1 /strona/wp-content/plugins/woocommerce/includes/class-wc-install.php(322): WC_Install::create_options()
    #2 /strona/wp-content/plugins/woocommerce/includes/class-wc-install.php(205): WC_Install::install()
    #3 /strona/wp-includes/class-wp-hook.php(307): WC_Install::check_version()
    #4 /strona/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #5 /strona/wp-includes/plugin.php(474): WP_Hook->do_action()
    #6 /strona/wp-settings.php(587): do_action()
    #7 /strona/wp-config.php(101): require_once(‘…’)
    #8 /strona/wp-load.php(50): require_once(‘…’)
    #9 /strona/wp-admin/admin-ajax.php(22): require_once(‘…’)
    #10 {main}

    Strona przy której potrzebuję pomocy: [zaloguj się aby zobaczyć ten link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Widzę, że na stronie wtyczki też już dodałeś wpis. I dobrze.
    Tak jak napisał @ihereira musiał byś prześledzić/zbadać, w którym momencie wywala ten błąd, jakby to powiedzieć – przyłapać go.

    Komunikat mówi tylko o tym, że argument nr 1, wprowadzany do klasy musi być typu object|string a podano int czyli liczbę całkowitą. To może być wina samej klasy, albo nawet jakiś twoich ustawień na serwerze (wersja PHP albo inne).

    Gdybyś prześledził akcje w koszyku (krok po kroku), no i może logi serwera też coś podpowiedzą.

    Thread Starter vnoo

    (@vnoo)

    Temat rozwiązany – zmiana php na 7.4 załatwiła sprawę.

    • Ta odpowiedź została zmodyfikowana 7 months, 2 weeks temu przez vnoo.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Temat ‘błąd krytyczny’ jest zamknięty na nowe odpowiedzi.